100% CPU utilization while delivering mail (search aid: sending, processor)

RESOLVED WORKSFORME

Status

MailNews Core
Networking: SMTP
--
critical
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Vaclav Dvorak, Assigned: Scott MacGregor)

Tracking

({hang})

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130

When delivering email, while "Delivering mail" is displayed and the throbber is
throbbing, Mozilla uses 100% CPU. The SMTP server is smtp.volny.cz. The
transmission speed seems normal for my connection (analog modem), the only
problem is the processor utilization. After the sending is finished (or
interrupted by user), CPU falls back to zero.

Reproducible: Always

Steps to Reproduce:
1. Have a slow enough link or compose a big enough e-mail to observe the delivery.
2. Send the e-mail.

Actual Results:  
CPU utilization goes to 100% and stays there until delivery is finished.

Expected Results:  
Mozilla should use nearly no CPU while waiting for the network.

Comment 1

15 years ago
Can you try this:

-quit mozilla (and quicklaunch, if running)
-delete or rename XUL.mfl (in your profile dir)
-restart and try send a mail

Is the problem still there?

Possible dup of bug 168516.

As a general rule of the thumb:
Keep addons compatible (spellcheckers, themes etc) - and follow the installation
notes (install to an empty dir)
(Reporter)

Comment 2

15 years ago
No, deleting XUL.mfl doesn't help. In fact, I even tried creating a completely
new profile, setting it to use POP instead of IMAP (my normal profile uses IMAP)
and didn't even allow it to login to the POP server (didn't enter password). So
even with a fresh profile and different situation, the problem is still there.
Also, note that Moz doesn't hang, it just uses 100% CPU until the send is done.
So not a dupe of 168516.

I would try a more current version, but with 1.3b just around the corner (I
suppose), I'm hesitant to download those 10MB's as I only have a slow and
expensive dial-up connection. :-( When 1.3b is out, however, I will surely test it.

As for addons, I don't think I have any that matter. I have the Shockwave Flash
6.0 r29 and QuickTime 5.0.2 plugins. When upgrading Mozilla, I always exit
quicklaunch, backup (but keep) profile, uninstall the current version (with the
Windows' Control Panel) and install new version. Is that enough, or should I
even delete and re-create the profile? Or ensure that the installation directory
is completely empty after uninstallation (and reinstall plugins then)?
(Reporter)

Comment 3

15 years ago
Okay, I downloaded 1.3b (and installed to a completely empty directory), and the
problem has actually gotten much worse. Now, while delivering the message, the
CPU utilization is still 100%, but when I click Cancel, it _stays_ at 100% while
the "sending mail has failed" window appears. When I click OK on that dialog, it
sometimes disappears (not always), but then Mozilla hangs (always) and CPU
utilization stays at 100%.

Setting severity to critical because of hang. (I can do that as the reporter,
right?)
Severity: normal → critical

Updated

15 years ago
Blocks: 193931
Keywords: hang

Comment 4

15 years ago
-- Is the computer you are running Mozilla on running an antivirus program? If
so, please detail what program and what version it is. Temporarily disable the
antivirus program. Then try to reproduce the problem you describe. Does the
problem still occur?

-- Go to Edit | Mail & Newsgroup Account Settings | Outgoing Server (SMTP) and
check "never" on whether to use a secure connection (SSL). Now try to reproduce
the problem. Does it still occur?

-- Go to Edit | Mail & Newsgroup Account Settings. In the appropriate account,
under Copies & Folders, unselect "place a copy in." Now try to reproduce the
problem. Does it still occur? If this works, is this an IMAP account? Are there
many messages in the sent folder?

-- Is the computer behind a firewall? If so, temporarily disable it, or put the
computer directly on the Internet. Can you still reproduce the problem? If not,
what product and version number is the firewall?

-- Delete all your SMTP server entries. Exit Mozilla. Restart Mozilla. Recreate
all your SMTP server entries. Can you still reproduce the problem?

-- Do you have spellchecker installed? If so, disable it or remove it. Does that
solve the problem?

-- Is your profile hosted on a network drive (or NFS mount)? 

If none of these steps work, please attach an SMTP log. The steps for creating
the log can be found here:

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap
(Reporter)

Comment 5

15 years ago
Just a quick note before I have time to try the more time-consuming steps.

> Is the computer you are running Mozilla on running an antivirus program?

No.

> Go to Edit | Mail & Newsgroup Account Settings | Outgoing Server (SMTP) and
> check "never" on whether to use a secure connection (SSL). Now try to

It is already set to "never" - I guess it's the default. (Why isn't "when
available" the default? Are there known problems with it?)

> Go to Edit | Mail & Newsgroup Account Settings. In the appropriate account,
> under Copies & Folders, unselect "place a copy in."

I can try that later, but note that Mozilla hogs the CPU during _delivering_ of
the message, i.e. _before_ it starts placing the copy in Sent folder. I don't
know what happens during the hang after clicking Cancel, though.

> is this an IMAP account? Are there many messages in the sent folder?

Yes, it is IMAP. How many is many? There are exactly 375.

> Is the computer behind a firewall? If so, temporarily disable it, or

Well, yeah. I have a Linux router/firewall/IMAP server that manages the dial-up
connection. So should I open all ports and try sending mail or what? How should
that be related? (But note that the SMTP server is _not_ this Linux, it's the
ISP's mailserver.)

> put the computer directly on the Internet.

You mean like server-housing at an ISP? ;-) I wouldn't like that, there's mostly
very cold in these rooms. Not surfer-friendly. :-)

> Delete all your SMTP server entries. Exit Mozilla. Restart Mozilla. Recreate
> all your SMTP server entries. Can you still reproduce the problem?

Will try later.

> Do you have spellchecker installed?

No.

> Is your profile hosted on a network drive (or NFS mount)?

No.

> If none of these steps work, please attach an SMTP log.

Will do.

Thanks for the assistance.

BTW, has anyone tried to reproduce this on Win98 but failed? Can I mark this bug
NEW now that I have the canconfirm Bugzilla privilege?

Comment 6

15 years ago
Quick reply to your question: yes, please do.
(Reporter)

Comment 7

15 years ago
So I've done the experiments, and the bug's still there. I'll describe as
precisely as I can.

I made a completely new profile (Tools->Switch Profile->Create, then Use
Profile). I set up a mail account with the same SMTP server that I normally user
(smtp.volny.cz) but with a POP3 server for incoming mail, which I set to
localhost and didn't ever try connecting to it. (I.e. there wasn't any POP3 or
IMAP activity.) I set up the SMTP logging and also started a download (not in
Mozilla) so that the line would be busy and I would have plenty of time to watch
the progress.

I composed a message to myself and attached a big (0.5MB) file and hit Send.
"Sending message" appeared for perhaps 10 seconds (probably OK because of the
download - I assume that at this stage, the SMTP connection is being
initialized), but CPU utilization was near zero. Then "Delivering message"
appeared and CPU jumped to 100%. As I didn't want to wait long, I hit Cancel
after a while. The progress dialog disappeared and instead, the "Sending message
failed" dialog appeared. CPU was still at 100%. I clicked OK in the dialog. It
disappeared, but Mozilla was frozen and I had to kill it. CPU was still at 100%
until I killed Mozilla.

Second experiment: using the same profile, I turned off saving copies of sent
mail and composed a message to self with a shorter attachment (about 100KB) and
hit Send. Sending message - CPU=0%, delivering message - CPU=100%, then done,
CPU=0%. I.e. all OK, except for CPU utilization during delivering.

Third experiment: using the same profile, I composed a message to self with no
attachment, and instead a lot of text in body. (The body was just text/plain.)
Same thing: sending/0%, delivering/100%, Cancel, sending failed/100%. But at
this point, after a while, when the "Sending failed" was still displayed, the
CPU dropped to 0% as the body of the message probably finished sending in the
background (there's a dot in the log). I clicked OK, "sending failed"
disappeared, CPU went back to 100% and Mozilla froze. I had to kill it again.

Summary: this bug is actually _two_ bugs. The 100% CPU utilization during
"delivering", which was present already in 1.2.1 (but possibly earlier). And the
hang after canceling the delivering process, which appeared between 1.2.1 and
1.3b. Both are independent on IMAP/POP, on saving copy of sent message, on SSL,
on XUL.mfl, and on anything left over from past profiles.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 8

15 years ago
Created attachment 114970 [details]
SMTP log of first experiment (aborted send)
(Reporter)

Comment 9

15 years ago
Created attachment 114971 [details]
SMTP log of second experiment (successful send)
(Reporter)

Comment 10

15 years ago
Created attachment 114974 [details]
SMTP log of third experiment (semi-aborted send)

I forgot to mention: though this third attempt was cancelled during the
"delivering mail" process, the mail was actually sent eventually (it came back
to me).

Comment 11

15 years ago
I am seeing exactly the same symptoms with exactly the same settings as 
original poster on Win2000 with 1.3 final, and I have also tried all of the 
steps mentioned below.  There are now over 30! bugs related to 99% CPU 
utilization under Mail/News - and it is clear that many of the problems are not 
resolved by deleting XUL.mfl (bug 168516).

Comment 12

15 years ago
I'm under win xp with mozilla 1.4b 
and when i create a new account, the process mozilla.exe stay at 100%cpu
utilization. i can't manage the new user tree
Product: MailNews → Core

Comment 13

12 years ago
*** Bug 313280 has been marked as a duplicate of this bug. ***

Comment 14

12 years ago
Vaclav is this still a problem?
(Reporter)

Comment 15

12 years ago
(In reply to comment #14)
> Vaclav is this still a problem?

I haven't seen the problem for a long time now, but I haven't used Win98 for a long time, either, so I can't really say whether it's fixed or not. As far as I'm concerned, you can close the bug if you want.

Comment 16

12 years ago
closing WORKSFORME per reporter comment 15
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.