Chimera crashed during page reload (TalkBack did not activate)

RESOLVED WORKSFORME

Status

Camino Graveyard
General
--
critical
RESOLVED WORKSFORME
15 years ago
15 years ago

People

(Reporter: Matt Carrell, Assigned: saari (gone))

Tracking

({crash, stackwanted})

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/51 (like Gecko) Safari/51
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20021220 Chimera/0.6+Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20021220 Chimera/0.6+Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20021220 Chimera/0.6+Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20021220 Chimera/0.6+

Chimera crashed without bringing up Talkback.  Odd.  Must be a really severe crash.  This crash does not look to be of the same type as #189749. 

Reproducible: Sometimes

Steps to Reproduce:
1.  Load URL2.  Repeatedly press reload.. reload reload reload3.
Actual Results:  
After reloading 5x it crashed.

Expected Results:  
not crash or at least Talkback should have handled it.

**********Date/Time:  2003-01-19 23:46:39 -0800OS Version: 10.2.3 (Build 6G30)Host:       iMac-DV-SE-G3-Upstairs.local.Command:    NavigatorPID:        437Exception:  EXC_BAD_ACCESS (0x0001)Codes:      KERN_INVALID_ADDRESS (0x0001) at 0x28044242Thread 0 Crashed: #0   0x05003800 in PL_DHashTableOperate #1   0x05004bfc in GetAtomHashEntry(nsAString const&) #2   0x05004c70 in NS_NewAtom(nsAString const&) #3   0x00219c38 in nsNodeInfoManager::GetNodeInfo(nsAString const&, nsIAtom*, int, nsINodeInfo*&) #4   0x002537e4 in HTMLContentSink::CreateContentObject(nsIParserNode const&, nsHTMLTag, nsIDOMHTMLFormElement*, nsIWebShell*, nsIHTMLContent**) #5   0x00254c20 in SinkContext::OpenContainer(nsIParserNode const&) #6   0x002590f0 in HTMLContentSink::OpenContainer(nsIParserNode const&) #7   0x00339cb4 in CNavDTD::OpenContainer(nsCParserNode const*, nsHTMLTag, int, nsEntryStack*) #8   0x003364b0 in CNavDTD::HandleDefaultStartToken(CToken*, nsHTMLTag, nsCParserNode*) #9   0x00337130 in CNavDTD::HandleStartToken(CToken*) #10  0x00335ac4 in CNavDTD::HandleToken(CToken*, nsIParser*) #11  0x00334bdc in CNavDTD::BuildModel(nsIParser*, nsITokenizer*, nsITokenObserver*, nsIContentSink*) #12  0x0033d804 in nsParser::BuildModel() #13  0x0033d508 in nsParser::ResumeParse(int, int, int) #14  0x0033c9f4 in nsParser::ContinueParsing() #15  0x001a0440 in CSSLoaderImpl::Cleanup(URLKey&, SheetLoadData*) #16  0x001a0abc in CSSLoaderImpl::SheetComplete(nsICSSStyleSheet*, SheetLoadData*) #17  0x001a0c78 in CSSLoaderImpl::ParseSheet(nsIUnicharInputStream*, SheetLoadData*, int&, nsICSSStyleSheet*&) #18  0x001a0e48 in CSSLoaderImpl::DidLoadStyle(nsIStreamLoader*, nsString*, SheetLoadData*, unsigned) #19  0x001a0274 in SheetLoadData::OnStreamComplete(nsIStreamLoader*, nsISupports*, unsigned, unsigned, char const*) #20  0x0015d1ac in nsStreamLoader::OnStopRequest(nsIRequest*, nsISupports*, unsigned) #21  0x0045b8a8 in nsHttpChannel::OnStopRequest(nsIRequest*, nsISupports*, unsigned) #22  0x007d2a28 in nsOnStopRequestEvent::HandleEvent() #23  0x050500e4 in PL_HandleEvent #24  0x0504ffdc in PL_ProcessPendingEvents #25  0x05050f8c in nsEventQueueImpl::ProcessPendingEvents() #26  0x003d7278 in -[EventQueueHandler eventTimer:] #27  0x907e521c in __NSFireTimer #28  0x901632f0 in __CFRunLoopDoTimer #29  0x90148e48 in __CFRunLoopRun #30  0x90180fe4 in CFRunLoopRunSpecific #31  0x969a36a0 in RunCurrentEventLoopInMode #32  0x969b3440 in ReceiveNextEventCommon #33  0x969da584 in BlockUntilNextEventMatchingListInMode #34  0x9308d8ac in _DPSNextEvent #35  0x9309fb04 in -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] #36  0x930b15e4 in -[NSApplication run] #37  0x9315f6b8 in NSApplicationMain #38  0x00004440 in _start #39  0x000042c0 in startThread 1: #0   0x90073c48 in mach_msg_trap #1   0x90005f90 in mach_msg #2   0xc0007754 in __ape_internal #3   0xc000119c in __ape_agent #4   0x90020d48 in _pthread_bodyThread 2: #0   0x900257ac in select #1   0x0101c67c in poll #2   0x01018e50 in _pr_poll_with_poll #3   0x00178d5c in nsSocketTransportService::Run() #4   0x05052758 in nsThread::Main(void*) #5   0x0101a2bc in _pt_root #6   0x90020d48 in _pthread_bodyThread 3: #0   0x9003eaa8 in semaphore_wait_signal_trap #1   0x9003e8c4 in _pthread_cond_wait #2   0x010154f8 in PR_WaitCondVar #3   0x00147b44 in nsDNSService::DequeuePendingQ() #4   0x00147570 in nsDNSService::Run() #5   0x05052758 in nsThread::Main(void*) #6   0x0101a2bc in _pt_root #7   0x90020d48 in _pthread_bodyThread 4: #0   0x90042688 in semaphore_timedwait_signal_trap #1   0x9003e8b4 in _pthread_cond_wait #2   0x010152bc in pt_TimedWait #3   0x0101550c in PR_WaitCondVar #4   0x0505616c in TimerThread::Run() #5   0x05052758 in nsThread::Main(void*) #6   0x0101a2bc in _pt_root #7   0x90020d48 in _pthread_bodyThread 5: #0   0x90014d28 in syscall_thread_switch #1   0x907f4304 in +[NSThread sleepUntilDate:] #2   0x93081694 in -[NSUIHeartBeat _heartBeatThread:] #3   0x9081cd38 in forkThreadForFunction #4   0x90020d48 in _pthread_bodyThread 6: #0   0x9003eaa8 in semaphore_wait_signal_trap #1   0x9003e8c4 in _pthread_cond_wait #2   0x010154f8 in PR_WaitCondVar #3   0x05053844 in nsThreadPool::GetRequest(nsIThread*) #4   0x05054130 in nsThreadPoolRunnable::Run() #5   0x05052758 in nsThread::Main(void*) #6   0x0101a2bc in _pt_root #7   0x90020d48 in _pthread_bodyPPC Thread State:  srr0: 0x05003800 srr1: 0x0000f930                vrsave: 0x00000000   xer: 0x00000000   lr: 0x05003800  ctr: 0x050063b0   mq: 0x00000000    r0: 0x05003800   r1: 0xbfffdb20   r2: 0x88044244   r3: 0x28044242    r4: 0x28044242   r5: 0x0079d98e   r6: 0x00000001   r7: 0xbfffdce0    r8: 0x00000000   r9: 0x00000000  r10: 0x00000015  r11: 0x050aaee8   r12: 0x88044244  r13: 0x00000000  r14: 0x00000000  r15: 0x00000001   r16: 0xfffffffd  r17: 0x023a8430  r18: 0xbfffe680  r19: 0x02b18d58   r20: 0x00874458  r21: 0x00000000  r22: 0x02ceeedc  r23: 0xbfffde10   r24: 0xbfffdcf0  r25: 0xbfffdce0  r26: 0x0079d98e  r27: 0x00000800   r28: 0x050b34c4  r29: 0x00000001  r30: 0x6b29d522  r31: 0x05004b94
(Reporter)

Updated

15 years ago
Keywords: crash

Comment 1

15 years ago
WorksForMe using Chimera/2003021707, successfully reloading the URL ten times
(though I have the About ad server, f.about.com, blocked, which could be important).

Matt, can you still reproduce this problem using a current nightly build? If so,
please try to record a stack trace using the Console application's crash
reporting function.
Keywords: stackwanted
Summary: Chimera crashed during page reload and Talkback did not pop up. → Chimera crashed during page reload (TalkBack did not activate)
(Reporter)

Comment 2

15 years ago
Can't provide stack trace.. That crash was a one time event.. Doesn't seem repeatable on my system.. There wasn't a stack trace at the time of that crash.  Quite odd.  Perhaps also the reason TalkBack did not catch it?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Updated

15 years ago
Blocks: 201894
You need to log in before you can comment on or make changes to this bug.