text slightly overlaps other elements' text on the same line

RESOLVED WORKSFORME

Status

Core Graveyard
GFX: Mac
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Sean McGovern, Assigned: Simon Fraser)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [font spacing], URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20030113 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20030113 Chimera/0.6+

In the URL listed above, some of the text (particularly when the style changes)
is rendered overlayed on the previous style run.

Reproducible: Always

Steps to Reproduce:
1. Surf to said URL in Chimera
2. Observe wrong text rendering.

Comment 1

16 years ago
Also in Moz 1.2.1
Status: UNCONFIRMED → NEW
Component: General → Layout
Ever confirmed: true
Product: Chimera → Browser
Version: unspecified → Trunk

Comment 2

16 years ago
Also in Mozilla 1.3 on Windows. Mozilla/5.0 (Windows; U; WinNT4.0; en-US;
rv:1.3) Gecko/20030312

Additional URLs showing the problem are:

http://www.usairways.com/travel/inflight/electronic/index.htm
http://www.usairways.com/travel/inflight/inflight_cafe/index.htm
->default owner
Assignee: saari → other
QA Contact: winnie → ian

Comment 4

15 years ago
bug 200109 has been filed on a similiar case with another US Airways page. The
overflow on that page is as expected and a matter of overflow differences
between browsers / Tech Evangelism. I suspect the same for the pages in comment
2 as a quick scan shows lots of height declarations.

I haven't looked at the original page in this bug yet to know if that's the case
there too.
The USAirways pages are not related to this bug. Please do not add URLs to a bug
as in comment #2 unless you know they are being caused by the same bug.

The URL of this bug (linear.mv.com) WFM in build 2003040604, Win XP.

Comment 6

15 years ago
Slightly off-topic: Then I'm totally confused about how to report bugs. Bugzilla
specifically asks users not to open duplicate bugs. This bug describes exactly
what I saw on the pages referenced. How am I, a simple user, to know that they
are caused by the same bug?
This bug's summary is too vague.  Would you add additional comments to a bug
with a summary "page doesn't lay out correctly"?  This bug should not have been
confirmed.

(Also, I don't see the problem, and the lack of steps to reproduce doesn't help.)
Marking worksforme.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

15 years ago
In the phrase "This server has a mirror in Australia, the USA and another in the
USA.", part of the word "Australia" is overlayed on the word "in".
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 10

15 years ago
Now that I look at the original url (was just triaging the US Airlines site
before) I'm seeing this too... looks like theres some issues with the NOBR
sections and painting as they're all like 1em to the left (or perhaps one em too
wide... i'm not counting pixels)

I've seen this appearance in few bugs before tho (e.g. bug 198664), there may be
a bug out there already.

OS X 2003041008


screen shot coming for this page but
http://bugzilla.mozilla.org/attachment.cgi?id=118100&action=view is the effect
i'm seeing
Whiteboard: DUPEME

Comment 11

15 years ago
Created attachment 120410 [details]
screenshot

here's a screen shot with a few bad areas highlighted. After sizing things up
in photoshop the body type (english at least) seems to be 13px Verdana (not
font face defined in page)
So this looks like a Mac-only text measurement bug.
Assignee: other → sfraser
Status: REOPENED → NEW
Component: Layout → GFX: Mac
Summary: text is overlayed on other text where it shouldn't be → text slightly overlaps other elements' text on the same line
(Reporter)

Comment 13

15 years ago
Looks OK in Camino 2003090102. Can this bug be closed now?

Comment 14

15 years ago
yeah.. the url looks fine on my end as well... so I'll close it

-> WFM
Status: NEW → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME
Whiteboard: DUPEME → [font spacing]
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.