Last Comment Bug 189784 - cookies do not recognize port number
: cookies do not recognize port number
Status: RESOLVED INVALID
:
Product: Core
Classification: Components
Component: Networking: Cookies (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Darin Fisher
: Tom Everingham
Mentors:
http://villeneuve-tolosane.net:8889/s...
: 197925 295396 316733 329028 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-20 06:33 PST by Marc Quinton
Modified: 2006-03-25 21:19 PST (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Marc Quinton 2003-01-20 06:33:01 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021126
Build Identifier: "Mozilla/5.0"

When you have 2 servers : http://host:port1/ and http://host:port2/, the sames
cookies are sent to the server.


Reproducible: Always

Steps to Reproduce:
1. look at http://quinton.free.fr/mozilla/session1.php.txt
2. configure variable $host, and port number below,
3. install 2 http server on 2 different ports, that point to this script
4. copy session1.php.txt to session1.php
5. copy session1.php.txt to session2.php
6. verify that session variable (test_login) is transmited
7. look a session ID and verify if ID is the same for the 2 server (should not).
Comment 1 Marc Quinton 2003-01-20 06:36:56 PST
free of bug in 1.0, 1.1
bug started in 1.2, still in 1.3a
Comment 2 Marc Quinton 2003-01-20 22:57:55 PST
you can now make some tests online : 

  http://villeneuve-tolosane.net:8889/session1.php

clic on the 2 server and verify that cookies are the same or different.

may be I change apache httpd.conf (ServerName)
Comment 3 benc 2003-01-21 23:49:05 PST
This might be WONTFIX, based on Bug 142803, although I personally disagree w/
the interpretation, I've been on cookie qa for about 10 minutes.

I'll research this some more.
Comment 4 Boris Zbarsky [:bz] 2003-01-31 09:06:24 PST
This is invalid.  See bug 142803, which references the relevant specifications
(and the fact that we and IE both follow those specifications at this point is
nice too).
Comment 5 R.K.Aa. 2003-03-17 20:06:20 PST
*** Bug 197925 has been marked as a duplicate of this bug. ***
Comment 6 Josh Birnbaum 2005-11-16 11:05:05 PST
*** Bug 316733 has been marked as a duplicate of this bug. ***
Comment 7 :Gavin Sharp [email: gavin@gavinsharp.com] 2006-03-25 21:19:23 PST
*** Bug 295396 has been marked as a duplicate of this bug. ***
Comment 8 :Gavin Sharp [email: gavin@gavinsharp.com] 2006-03-25 21:19:27 PST
*** Bug 329028 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.