voting info not displayed when editing/viewing a bug

RESOLVED FIXED in Bugzilla 2.18

Status

()

P3
normal
RESOLVED FIXED
16 years ago
6 years ago

People

(Reporter: jnerad, Assigned: jnerad)

Tracking

unspecified
Bugzilla 2.18
x86
Linux
Bug Flags:
approval +

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212

The voting information is not being displayed when editing or viewing a bug.  I
think this relates to the namespace used in edit.html.tmpl.

Reproducible: Always

Steps to Reproduce:
1. grab a new 2.17.3 from cvs
2. make sure voting stuff is set up in product and prefs.
3. 

Actual Results:  
I don't see the voting information line

Expected Results:  
It should show something like 

Votes:  0    Show votes for this bug    Vote for this bug
(Assignee)

Comment 1

16 years ago
Created attachment 112056 [details] [diff] [review]
A patch to edit.html.tmpl

This fixes the problem in my 2.17.3 installation

Updated

16 years ago
Attachment #112056 - Flags: review+

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: approval?
I haven't seen Jack around much before, so I doubt if he has checking privs. 
Burnus, care to do the honors?
Assignee: myk → jnerad
Flags: approval? → approval+

Comment 3

16 years ago
Checked in for Burnus

Checking in template/en/default/bug/edit.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/edit.html.tmpl,v  <--
  edit.html.tmpl
new revision: 1.31; previous revision: 1.30
done                                          

Just a minor future reference thing...
When creating a patch, if you do the diff from the main bugzilla directory (the
same directory where checksetup lives), the the person applying the patch
doesn't have to know ahead of time what directory you patched.  The path will be
in the patch file.

Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Updated

16 years ago
Priority: -- → P3
Target Milestone: --- → Bugzilla 2.18

Comment 4

16 years ago
Was RCS file: /cvsroot /mozilla /webtools /bugzilla /template /en /default /bug
/edit.html.tmpl ,v not good enough for you?
good enough for a human, but not for the 'patch' program.  patch reads either
the "diff" command line or the --- and +++ lines to determine what file to
patch.  So it then assumes you're patching a file in the current directory,
can't find it, and prompts the user for the file to patch.  Since it does
display the header to the user before prompting, you can just copy/paste, but
it's still annoying. :)  On a small patch like this it's not a big deal, but if
you're patching several files from the same diff file, it's a pain in the butt
to type every one :)
(Assignee)

Comment 6

16 years ago
My bad.  Sorry about that.  I'll try to do it right in the future.  Thanks for
the correction.
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.