Chimera crashes when opening any SVG image through location bar or through a hyperlink with CSS containing a:hover {font-weight: bolder;}

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: peterhil, Assigned: peterlubczynski-bugs)

Tracking

({crash})

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.0.1) Gecko/20021220 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.0.1) Gecko/20021220 Chimera/0.6+

I was examining ways to include SVG versions of some logos on my home page, and
after I decided to use regular links instead of embed or object, I found Chimera
to crash constantly.

After trimming the page to bare minimum, I found the crash to be caused by CSS
style containing a:hover {font-weight: bolder;} on a link to SVG image.

I have Adobe SVG Viewer plug-in 3.0x76 installed in /Library/Internet Plugins. I
tested with builds 2002122004 and 2003011804, both of them crash. Links to PNG
or SWF files will not crash Chimera.

Reproducible: Always

Steps to Reproduce:
1. Open either of the pages contained within the attachment
2 [review]. Click on either of the links (SVG or SVGZ)
3. Move back (at least backspace and toolbar button works) if Chimera did not
crash in step 2
Actual Results:  
a) Chimera loads the page with back button dimmed and crashes
or
b) Chimera crashes after trying to move back from the SVG file

Expected Results:  
Not crash, obviously... :-)
(Reporter)

Comment 1

16 years ago
Created attachment 112078 [details]
This tar/gzip compressed attachment contains two html files, one simple style sheet and two SVG images.
(Reporter)

Comment 2

16 years ago
Created attachment 112083 [details]
Crash log showing crash at OffsetRgn
(Reporter)

Comment 3

16 years ago
Some observations from additional testing:

1. Todays build still crashes when opening a SVG image (local or remote) through
location bar. (I did not test with a link with a:hover {font-weight: bolder;} in
the style sheet, but I assume that still causes a crash too)

2. Dragging a SVG image to browser window does NOT crash the broswser
3. Opening a local SVG image from toolbar bookmark does NOT crash browser

This seems to be similar with bug 169041, maybe this is duplicate?
Definitely this still crashes Chimera without exceptions.

BTW - I use Privoxy but that shouldn't interfere too much, right?
Summary: Crash with CSS containing a:hover {font-weight: bolder;} on links to SVG images → Chimera crashes when opening any SVG image through location bar or through a hyperlink with CSS containing a:hover {font-weight: bolder;}

Updated

16 years ago
Attachment #112083 - Attachment description: Crash log → Crash log showing crash at OffsetRgn
Attachment #112083 - Attachment mime type: application/octet-stream → text/plain

Comment 4

16 years ago
Crash confirmed using Chimera/2003021707, generating TB172799Z.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash

Comment 5

15 years ago
I can't confirm this bug using 2003081002 NB. WorksForMe.

Comment 6

15 years ago
taking.

jrh, do you have the plug in installed?
Status: NEW → ASSIGNED

Comment 7

15 years ago
Yes I have the Adobe SVG 3.0 plugin installed. And have no problems.

http://www.adobe.com/svg/viewer/install/main.html
(Reporter)

Comment 8

15 years ago
I have no problems either with more recent builds (I files this bug in January).
I'm using Camino build 2003062605 and I just downloaded and installed the Adobe
SVG plug-in again, but it's version seems to still be 3.0x76.

So, maybe this is fixed already?
(Reporter)

Comment 9

15 years ago
I have no problems either with more recent builds (I filed this bug in January).
I'm using Camino build 2003062605 and I just downloaded and installed the Adobe
SVG plug-in again, but it's version seems to still be 3.0x76.

So, maybe this is fixed already?

Comment 10

15 years ago
Downloaded Adobe SVG plugin and attachment files,
both links (and step-back routines) WFM - Build ID: 2003082702

Comment 11

15 years ago
->WFM based on multiple reports including reporter
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.