incorrect favicon displayed on non-root pages

VERIFIED DUPLICATE of bug 204393

Status

()

--
trivial
VERIFIED DUPLICATE of bug 204393
16 years ago
12 years ago

People

(Reporter: brett.donald, Assigned: hyatt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5

Phoenix sometimes displays the favicon from the root folder (www.tagnet.org)
instead of the favicon in my folder (www.tagnet.org/castlehill/). Compare with
Mozilla, which always displays the correct favicon (a cross).

Reproducible: Always

Steps to Reproduce:
1. Watch the favicon while browsing to the above URL
2. Watch the favicon while pressing refresh
Actual Results:  
Either of two things may happen:
1) Sometimes the correct favicon is displayed for a split second, but is then
overwritten with the incorrect favicon (from the root folder).
2) Sometimes the correct favicon is displayed, but when refresh is pressed it is
replaced with the incorrect favicon.

Expected Results:  
Phoenix should always display the favicon from the current folder, not the web
server's root folder.

Comment 1

16 years ago
Confirmed on 20030116 Linux. I get the correct icon in the tab itself (the
cross) but an incorrect icon (a character resembling an 'n' or a Greek 'pi') in
the location bar. The root url has what I assume is the correct n-like icon in
both locations.

-->New
-->All OS
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All

Comment 2

16 years ago
See also bug #204393. I think if that is solved this one will be fixed
automatically.
Duping this against 204393 as this is indeed the same issue, and 204393 has a
better explanation and a testcase.

*** This bug has been marked as a duplicate of 204393 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Taking QA Contact
QA Contact: asa → bugzilla
Mass-verifying. Sorry for bugspam.
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.