Search button does not invoke dialog, but garbage screen capture.

VERIFIED FIXED

Status

SeaMonkey
General
P1
major
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: scalkins, Assigned: Robert John Churchill)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Saw this on Win build 1999-11-16-09 M12 today
(Did not see this on Linux build today however)

Steps to repro:
1)Launch Seamonkey. When Mozilla comes up, type over default URL and input a
word in this field (i.e. "virus")
2) Click on the Search button to the right of the URL field.

Expected results:
Search Dialog box appears and you are prompted to select a location to search.
The word "virus" is pre-poulated in the Words: Field of the Search dialog.

Actual results: The Search Dialog box never appears. The entire screen including
the picture of Mozilla is "captured" in another window. If you try to move this
"window" it blurs the contents.
(Reporter)

Comment 1

18 years ago
This affects AIM also.
(Reporter)

Updated

18 years ago
Priority: P3 → P1
(Reporter)

Comment 2

18 years ago
This was still a problem on Win build 1999-12-08-16 M12. Setting P1 as this is
basic search functionality.
(Reporter)

Comment 3

18 years ago
In todays win build, the dialog opens, but the search engine list is missing so
you cannot perform a search (if you do it comes back empty, even when clicking
on the "Check All" button)

Updated

18 years ago
QA Contact: leger → paulmac

Comment 4

18 years ago
qa contact to paulmac.  Paul, can you assign to the right person? Thanks.

Updated

18 years ago
Assignee: leger → rjc
QA Contact: paulmac → claudius

Comment 5

18 years ago
I think this should start with robert. This works fine with Linux builds from
today.
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 6

18 years ago
I believe this was caused by other regressions in the tree which have been
fixed, so marking WORKSFORME since it does (on Windows) using a fresh pull of
the tip.

Updated

18 years ago
Status: RESOLVED → REOPENED

Comment 7

18 years ago
Re-opening, this is still a problem on commercial builds *only*, not a problem
with mozilla builds using 12/16 builds on win98.

The list of search engines does not appear. This is fine on linux.

So to summarize, this is a windows only, commercial only problem. And not a m12
stopper, as it is commercial only.

Updated

18 years ago
Resolution: WORKSFORME → ---
(Assignee)

Updated

18 years ago
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 8

18 years ago
I just (around 11 PM on Dec 16, 1999) did a full pull/build of mozilla as well
as the commercial tree and this works fine for me on Windows. Again, marking as
WORKSFORME.

Comment 9

18 years ago
Robert, I feel like a weenie to keep re-opening this, but it still occurs in
today's 12/17 builds. It must be packaging issue that can't be duplicated by
pulling and build the commercial tree.

I did a directory compare and the chrome\search directories are identical
between the mozilla and commercial builds, what else should I look for?

If you want to reproduce this, you can download the seamonkey32.exe installer at
ftp://sweetlou/products/client/seamonkey/windows/32bit/x86/current/

suzanne, am I smoking something here or do you still see it also?
(Assignee)

Comment 10

18 years ago
Hey Paul, no problemo.  :^)

I downloaded the seamonkey32.exe installer and indeed see the problem, which is
(as you guessed) that none of the files in
      mozilla\xpfe\components\search\datasets
are being packaged up into
      $(DIST)\res\rdf\datasets
which is weird since just pulling/building the mozilla then the ns trees does do
it.

So, that's the problem.  I don't know how to fix it though... can you re-assign
this bug to someone involved with creating the Commercial installer who would
know?

Updated

18 years ago
Status: RESOLVED → REOPENED

Comment 11

18 years ago
re-opening

Updated

18 years ago
Assignee: rjc → leaf
Status: REOPENED → NEW

Comment 12

18 years ago
Leaf, are you the man??? Just read robert's last comment.

Updated

18 years ago
Resolution: WORKSFORME → ---

Updated

18 years ago
Assignee: leaf → rjc

Comment 13

18 years ago
does the mozilla/xpinstall/packager/packages-{win,mac,unix} package manifest
have this stuff in it? Since i'm not totally sure what should be getting
packaged where, can you add it, rjc?
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 14

18 years ago
Thanks for the pointer, leaf.  Fix checked in.
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 15

18 years ago
Marking bug fixed.
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 16

18 years ago
Verified in Win build 1999-12-22-09 M13
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.