Message views setup: restores from "match any" to "match all" after saving settings

VERIFIED FIXED in mozilla1.3beta

Status

VERIFIED FIXED
16 years ago
14 years ago

People

(Reporter: kwuerfl, Assigned: sspitzer)

Tracking

Trunk
mozilla1.3beta
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212

When selecting more than one view filter (more... button) and selecting "match
any of the following", the latter setting restores automatically to "match all
of the following" when viewing the message view settings the next time (after
pressing ok to close the msg view windows). 

Reproducible: Always

Steps to Reproduce:
1. Message views -> customize
2. Add one filter, select "match any..." and press "more..." button
3. Add another filter, press "ok", and "ok" again in main msg view window
4. re-open msg view -> customize, filter will display "match all..." instead of
"any..."
Actual Results:  
see steps

Expected Results:  
see steps

Comment 1

16 years ago
Using build 20030119 on linux, I see this too, it's more of a problem than noted
here.  Acutally the frontend is switching back to matching all, but the backend
is still at match any so this it appears this functionality is broken when it's
not(per bug 186182). 
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Updated

16 years ago
Keywords: nsbeta1
from my mailViews.dat file:

name="aa"
enabled="yes"
type="1"
condition="AND (subject,contains,aaa) OR (subject,contains,aaab)"

I bet the mixed booleans is part of the problem.
when I create the view, I have:

name="aa"
enabled="yes"
type="1"
condition="OR (subject,contains,aaa) OR (subject,contains,aaab)"

but when I open it the second time, and then hit ok, I turns into:

name="aa"
enabled="yes"
type="1"
condition="AND (subject,contains,aaa) OR (subject,contains,aaab)"

investigating...
the problem is with LoadCustomMailView() in msgViewPickerOverlay.js

in order to work with quick search (QS), we set the boolean for the first term 
to be "and", and the front end code uses the boolean for the first term for the 
radio button.

the fix (testing a patch) is to clone the search terms before altering them for 
QS.
fix in hand, but still improving it.
QA Contact: laurel → esther
Target Milestone: --- → mozilla1.3beta
Created attachment 112268 [details] [diff] [review]
patch

patch, use a temporary search term array, since we will be modifying it for QS.
Created attachment 112271 [details] [diff] [review]
update, fix comment and an error in my patch
Attachment #112268 - Attachment is obsolete: true

Comment 8

16 years ago
Sorry the possible duplicate is bug 186162

Comment 9

16 years ago
*** Bug 186162 has been marked as a duplicate of this bug. ***
Attachment #112271 - Flags: review?(cavin)

Comment 10

16 years ago
Comment on attachment 112271 [details] [diff] [review]
update, fix comment and an error in my patch

r=cavin.
Attachment #112271 - Flags: review?(cavin) → review+
Attachment #112271 - Flags: approval1.3b?

Comment 11

16 years ago
Comment on attachment 112271 [details] [diff] [review]
update, fix comment and an error in my patch

a=asa (on behalf of drivers) for checkin to 1.3beta.
Attachment #112271 - Flags: approval1.3b? → approval1.3b+
fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 13

16 years ago
verified with trunk builds 20030211 on linux, 20030214 on winxp and maco osx.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.