in a table with set width a font tag can cause cell contents to leak out of cell

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
16 years ago
5 years ago

People

(Reporter: robert.peacock, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212

Take a table with size of table and cells specified.  In a cell, start with a
font tag.  If the text immediatly following the font tag is another tag,
formatting of the table is broken and contents of cell will leak into next.  In
the example I use a bold tag, but a span works too.  If the tags are in the last
column and the table is enclosed in another table, the cell contents will
overlay the contents of the outer table.  This was spotted on www.nytimes.com
where they do alot of table sizing.

Reproducible: Always

Steps to Reproduce:
1. View this page:
<html>
<body>	      

  <table width="200" border='1'>
    <tr>
      <td width="100">
        <font face="Times,Times New Roman,serif" size="-1"><b>some text in a tag
</b> heres some text heres some text</font>
      </td>
      <td width="100" bgcolor="green">
        &nbsp;
      </td>
    </tr>
  </table> 

</body>
</html>

Actual Results:  
Text from the first cell will leak into 2nd cell.

Expected Results:  
Text should wrap and stay within cell.
(Reporter)

Comment 1

16 years ago
Just to clarify, if you place any text between the font and bold tag, the table
will be displayed normally.

Comment 2

16 years ago
Created attachment 112154 [details]
table cell text overflow into next cell.

Work for me on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b)
Gecko/20030119.
Whiteboard: DUPEME

Comment 3

16 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030119
WFM no wrap

Comment 4

16 years ago
testcase wfm on 1.4 beta on winXP and linux
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.