When selecting Tools > Search > Messages Mozilla locks up in a 100% CPU loop

RESOLVED DUPLICATE of bug 169777

Status

SeaMonkey
MailNews: Message Display
--
major
RESOLVED DUPLICATE of bug 169777
16 years ago
10 years ago

People

(Reporter: Barry Treahy, Assigned: Navin Gupta)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

Something recently developed that is 100% reproducable now, and that is
everytime I want to search my messages using the Tools > Search > Messages,
Mozilla enters a 100% CPU loop and never returns (hours later) without any
dialog box appearing in response.  This wasn't an issue or a problem until this
week and no software or reg entries have been altered during this period; It
just started locking up.  As my luck has it, I have a dual processor, so Mozilla
is only killing one processor and not bringing my entire system to a halt...

Reproducible: Always

Steps to Reproduce:
1. Start e-mail client
2. Click on Tools > Search > Messages
3. Watch the CPU spin as nothing else happens...

Actual Results:  
Endless Process Looping

Expected Results:  
Produced a dialog box of search options

No talkback data gathered as Mozilla never actually crashes.  Oddly, if I
attempt to open the Java console, running 1.4se, the second processor enters the
loop.
Reporter:
Please close mozilla and rename the file "xul.mfl" in your mozilla profile.
(Reporter)

Comment 2

16 years ago
Splendid!  That fixed it.  Can someone educate me as to what that file does and
perhaps why this occurred as we have another less frequent MZ hangs and I'm
wondering if this might be the general 'cure' and if so, are there any negative
side-effects that I should be cautious of?
Please zip the file (the old one)and send it to jrgm@netscape.com

This file is a cache for Mozilla UI language "XUL"
(no personal data)


*** This bug has been marked as a duplicate of 169777 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey

Updated

10 years ago
Component: MailNews: Search → MailNews: Message Display
QA Contact: laurel → search
You need to log in before you can comment on or make changes to this bug.