Using arrow keys to change SELECT choice does not trigger onChange

RESOLVED DUPLICATE of bug 126379

Status

()

Core
Event Handling
RESOLVED DUPLICATE of bug 126379
15 years ago
15 years ago

People

(Reporter: Sam Hulick, Assigned: saari (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

Changing a select menu using the arrow keys does not trigger the onChange event
as it should.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
Not JavaScript Engine. Reassigning to Event Handling for further triage. 

Sam: could you attach a reduced testcase via the "Create a New Attachment"
link above? That will speed things along; thanks -
Assignee: rogerl → saari
Component: JavaScript Engine → Event Handling
QA Contact: pschwartau → trix

Comment 2

15 years ago
Created attachment 112181 [details]
onChange for Select.

Well, I see this bug. You should focus select and try up/down arrow to change
options. If onChange firing, alert pop-up.

Comment 3

15 years ago
Dupe of bug 126379. This behavior is desired, as I see.

*** This bug has been marked as a duplicate of 126379 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.