If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

automatic image resizing: state of the image should be kept after resizing the browser window

VERIFIED FIXED in mozilla1.8beta2

Status

()

Core
Layout: Images
P5
enhancement
VERIFIED FIXED
15 years ago
12 years ago

People

(Reporter: pcgod, Assigned: Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com])

Tracking

Trunk
mozilla1.8beta2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030121

the state of the image shouldn't change after resizing the browser window, ie 
if the image was restored to full size before resizing it shouldn't shrink back 
to the new size of the window but stay in full size.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

15 years ago
Created attachment 112187 [details] [diff] [review]
patch

this patch achieves the suggested behaviour
To jan
Assignee: jdunn → varga
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attachment #112187 - Flags: superreview?(jaggernaut)
Attachment #112187 - Flags: review?(varga)

Comment 3

15 years ago
Created attachment 112205 [details] [diff] [review]
patch2

I already wanted to do this, but instead of additional boolean variable I
changed mImageIsResized to mImageState.

Updated

15 years ago
Attachment #112187 - Flags: superreview?(jaggernaut)
Attachment #112187 - Flags: review?(varga)

Updated

15 years ago
Attachment #112205 - Flags: superreview?(bzbarsky)
Attachment #112205 - Flags: review?(jaggernaut)
Attachment #112205 - Flags: superreview?(bzbarsky) → superreview+

Updated

15 years ago
Status: NEW → ASSIGNED
Keywords: nsbeta1
why not make mImageState an enum? gives more friendly names in debuggers...
Will include in patch for bug 73322
Blocks: 73322

Updated

15 years ago
No longer blocks: 73322
Scratch that. The patch in this bug will be building off the one in bug 190545
when its checked in.
Depends on: 190545
Comment on attachment 112205 [details] [diff] [review]
patch2

Actually, they will all be just included in the same patch.
Attachment #112205 - Attachment is obsolete: true
Oops, sorry about the incorrect setting. Sorry about all the SPAM. The problem 
is that I can't change some bug settings at the same time as others.
Blocks: 190545
No longer depends on: 190545

Updated

15 years ago
No longer blocks: 190545
Depends on: 190545

Comment 9

15 years ago
Erh... Is that last patch truly obsolete?
Jan recommended that we just include this patch in the patch on bug 190545
(which is about to be revised) since bug 190545 has some changes to the
underlying code this patch fixes.

Updated

15 years ago
Priority: -- → P3
Target Milestone: --- → mozilla1.4beta

Comment 11

15 years ago
Created attachment 120998 [details] [diff] [review]
new patch

now with an enum :)
Attachment #112187 - Attachment is obsolete: true

Updated

15 years ago
Attachment #120998 - Flags: superreview?(jaggernaut)
Attachment #120998 - Flags: review?(cbiesinger)

Updated

15 years ago
Attachment #112205 - Flags: review?(jaggernaut)
Comment on attachment 120998 [details] [diff] [review]
new patch

Hm... this does not do the right thing completely... 

If I enable automatic image resizing, and load say http://www.mozilla.org/ and
make my browser window smaller than the image, larger than the image and then
again smaller, the image is still shown in its original size and not resized.
this works without the patch.
Attachment #120998 - Flags: review?(cbiesinger) → review-

Comment 13

15 years ago
Comment on attachment 120998 [details] [diff] [review]
new patch

ok, this needs a completely different approach
Attachment #120998 - Attachment is obsolete: true
Attachment #120998 - Flags: superreview?(jaggernaut)
I'm still working on bug 190545, and this issue is still fixed in my latest code
for that bug (the current patch as of writing this is obsolete).

Comment 15

15 years ago
*** Bug 203174 has been marked as a duplicate of this bug. ***

Comment 16

15 years ago
adt: nsbeta1-
Keywords: nsbeta1 → nsbeta1-

Comment 17

15 years ago
*** Bug 203146 has been marked as a duplicate of this bug. ***

Comment 18

14 years ago
*** Bug 210359 has been marked as a duplicate of this bug. ***
Blocks: 190545
No longer depends on: 190545
I don't understand comment 12, but I think I can do something reasonable.
Assignee: jan → cst
Status: ASSIGNED → NEW
Priority: P3 → P5
QA Contact: tpreston → stephend
Target Milestone: mozilla1.4beta → mozilla1.8beta2
Created attachment 178979 [details] [diff] [review]
patch

With this patch, resizing the window does not toggle scaling (if it was scaled
before, it continues to be scaled, and if it wasn't, it stays full size until
you click).
Attachment #178979 - Flags: superreview?(roc)
Attachment #178979 - Flags: review?(caillon)
Whiteboard: r?
Attachment #178979 - Flags: superreview?(roc) → superreview+
Attachment #178979 - Flags: review?(caillon) → review?(bzbarsky)
Comment on attachment 178979 [details] [diff] [review]
patch

>Index: content/html/document/src/nsImageDocument.cpp
>   PRPackedBool                  mImageIsResized;
>+  PRPackedBool                  mShouldResize;

Please document how the latter differs from the former, ok?

>+  PRBool wasResized = mImageIsResized;

That var looks unused.	Take that out?

With that, r=bzbarsky
Attachment #178979 - Flags: review?(bzbarsky) → review+
checked in
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Whiteboard: r?
(Reporter)

Comment 23

13 years ago
Verified that this Bug is fixed.
Version: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050409 Firefox/1.0+
Status: RESOLVED → VERIFIED
*** Bug 252437 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.