Mozilla ignores external CSS files in xhtml

RESOLVED INVALID

Status

()

Core
DOM: CSS Object Model
RESOLVED INVALID
16 years ago
16 years ago

People

(Reporter: Oren Hazi, Assigned: jst)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

The page http://wildcat.mchschool.org/ is xhtml transitional. It includes a
"link" tag in the head section that points to an external CSS file (located at
http://www.mchschool.org/common/library/layout.css). When you load the page in
Mozilla, the stylesheet is completely ignored, but in Netscape or IE, the
stylesheet is displayed properly. 

Reproducible: Always

Steps to Reproduce:
1. Load the page above. 
Actual Results:  
The page loaded in the default font with the default bullet style. 

Expected Results:  
The page should have loaded in a different font, and used a specified image as
the bullet (defined in the external stylesheet). 

This has happened on Windows XP using Mozilla 1.2.1 (current), and on RedHat
Linux using Mozilla 1.0.1 (old).
see tools/web Development/ Javascript Console :

Error: The stylesheet http://www.mchschool.org/common/library/layout.css was not
loaded because its MIME type, "text/html", is not "text/css".


The server sends the wrong mime-type for the css file

-> invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.