popup windows: should prefill whitelist and highlight blacklist entries

VERIFIED INVALID

Status

SeaMonkey
Preferences
VERIFIED INVALID
15 years ago
13 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: shliang)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.47 KB, patch
jag (Peter Annema)
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

15 years ago
found using 2003.01.21.10 comm trunk builds. with the popup window feature, we
should prefill whitelist and highlight blacklist entries when the user either
clicks on the notification icon or selects Tools - Popup Manager - Manage Popup
Permissions.

it worked fine in Netscape 7.01, so it'd be nice to have this behavior in the trunk.
(Reporter)

Comment 1

15 years ago
i believe shuehan already has a fix for this. woo!
(Assignee)

Comment 2

15 years ago
Created attachment 112223 [details] [diff] [review]
patch
(Assignee)

Updated

15 years ago
Attachment #112223 - Flags: review?(jaggernaut)

Comment 3

15 years ago
Comment on attachment 112223 [details] [diff] [review]
patch

sr=jag
Attachment #112223 - Flags: superreview+

Comment 4

15 years ago
*** Bug 190216 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
Would it be technically possible for the popup blocked icon to load the blocked
window on the spot?  As I understand it, the current procedure would be:
A) perform action that would normally cause a popup (browse to window, click on
graphic)
B) click on icon, add site to whitelist
C) repeat action in A

Which is a little clunkier than it could be.  Something along the lines of:
Mouseover of popup icon shows blocked URL in the status bar
Right click of icon brings up whitelist dialog
Left click of icon loads the blocked url(s) in popup windows.
(Assignee)

Comment 6

15 years ago
fixed last week
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Updated

15 years ago
Attachment #112223 - Flags: review?(jaggernaut)
(Reporter)

Comment 7

15 years ago
this works fine when i access Exceptions from the notification icon in the
status bar.

however, there's still no prefilling / highlighting when i access Exceptions via
the menu item Tools - Popup Manager - Manage Popup Permissions.

tested with 2003.02.03 comm trunk bits on linux rh7.2 and mac 10.2.3.

shuehan, i'm reopening this bug --but if you'd rather i file a separate one for
the menu item issue, let me know and this could be re-resolved. thanks!
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 8

15 years ago
Nav triage team: need info.  Is the menu item staying?  Shuehan, please update
us in the bug when a decision based on recent usability studies about the Tools
menu items has been made.  Thanks.
Whiteboard: [need info]

Comment 9

15 years ago
Nav triage team: Shuehan, can you supply requisite info please?  Is this still
an issue?  Thanks.
(Reporter)

Comment 10

15 years ago
this is no longer an issue, due to bug 195924.
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Keywords: nsbeta1
Resolution: --- → INVALID
Whiteboard: [need info]
(Reporter)

Comment 11

15 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.