Highlighted/focused text fields in XUL and HTML clobbers X Primary

RESOLVED DUPLICATE of bug 188440

Status

()

RESOLVED DUPLICATE of bug 188440
16 years ago
16 years ago

People

(Reporter: jon, Assigned: jag-mozilla)

Tracking

Trunk
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.2.1) Gecko/20021227
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.3b) Gecko/20030118

Between 1/9 and 1/10, text fields in forms, the location bar, the open web
location, find dialog, file open dialog, etc. began asserting X primary as the
control's contents are highlighted upon receiving focus.  

There are bugs separately addressing the location bar behavior and the open web
location behavior, the latter behavior changing coincident with the above.

The 1/10 nightly build clobbers, 1/9 does not.

Directory: 2003-01-10-16-trunk   01/10/03  16:31:00
Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.3b) Gecko/20030111

Directory: 2003-01-09-16-trunk   01/09/03  16:31:00
Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.3b) Gecko/20030110

While setting the autocopy pref prevents the unwelcome primary assertions, it
also renders unusable in mozilla one of X's finer features;)

Reproducible: Always

Steps to Reproduce:

1. Select some text (your favorite text editor, xterm, whetever).
2. Perform a find in mozilla by raising the find dialog (e.g. <CTRL><F> or
however you prefer).  
   Repeat the search until the `... text entered was not found ...' message is
displayed.  
3. Dismiss the above alert.
4. The search text (`Find text') is now highlighted in the find dialog (this is
not new) and the selected text from 1.) is no longer selected (this is the new
part).
5. Paste from primary to confirm that it now contains the search text.


1. Select some text (your favorite text editor, xterm, whetever).
2. Populate a text field on a form.
3. Focus something else, such that the field from 2.) may be tabbed into.
4. Tab into that field, noting that its contents are highlighted and have
replaced the X primary as the above case.


1. Select some text (your favorite text editor, xterm, whetever).
2. Raise the open file dialog (<CTRL><O> or however you prefer)
3. Type something in the `File name' field.  
4. Tab out of the field and back in.  X primary gets clobbered. 


1. Raise the page setup dialog (File menu;)
2. Uncheck `Fit to page...' and highlight/select the scale.  Primary gets
asserted as expected.
3. Select some text in another window (your favorite text editor, xterm, whetever).
4. Focus the page setup dialog again, and primary is reasserted.

Actual Results:  
X primary gets clobbered.

Expected Results:  
X primary does not get clobbered: either text is highlighted and the X primary
untouched as had been the case prior to 1/10, or, nothing is highlighted in the
text field, and the caret is placed as it was when the field last had focus
(e.g. typical GTK behavior AFAIK).
This was fixed earlier today.  Note that something is fishy with the dates you
have there, since the regression happened before 2003-01-09-08....

*** This bug has been marked as a duplicate of 188440 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.