Marking as blocking and resolving in a single commit creates a very ugly message.

VERIFIED DUPLICATE of bug 179351

Status

()

VERIFIED DUPLICATE of bug 179351
16 years ago
6 years ago

People

(Reporter: mozilla-bugs, Assigned: preed)

Tracking

Details

(Reporter)

Description

16 years ago
I've just marked bug 189563 as blocking 59652 at the same time marking it as
RESOLVED FIXED (it was in "ASSIGNED" state). The bugmail it generated for bug
59652 (see below) is completely messed up:
1) It does *not* say that a new bug was added to its dependency list
2) The "state change" message is repeated twice
3) The "state change" message includes NEW -> ASSIGNED transition that happened
well before the dependency was added (so it shouldn't be included).

The bugmail I received was the following:
------
http://bugzilla.mozilla.org/show_bug.cgi?id=59652


mozilla-bugs@nogin.org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
Bug 59652 depends on bug 189563, which changed state.

Bug 189563 Summary: use of uninitialized value found by valgrind
http://bugzilla.mozilla.org/show_bug.cgi?id=189563

           What    |Old Value                   |New Value
----------------------------------------------------------------------------
             Status|NEW                         |ASSIGNED
             Status|ASSIGNED                    |RESOLVED
         Resolution|                            |FIXEDBug 59652 depends on bug
189563, which changed state.

Bug 189563 Summary: use of uninitialized value found by valgrind
http://bugzilla.mozilla.org/show_bug.cgi?id=189563

           What    |Old Value                   |New Value
----------------------------------------------------------------------------
             Status|NEW                         |ASSIGNED
             Status|ASSIGNED                    |RESOLVED
         Resolution|                            |FIXED
(Assignee)

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 179351 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

16 years ago
Sorry, indeed a dup.
Status: RESOLVED → VERIFIED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.