url bar not responding to tab or enter properly

VERIFIED FIXED in mozilla1.3beta

Status

SeaMonkey
Location Bar
P1
blocker
VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: tor, Assigned: peterv)

Tracking

({smoketest})

Trunk
mozilla1.3beta
smoketest

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
In the January 22nd linux nightly, typing something into the urlbar and then
hitting tab to select an item instead focuses the content area.  Typing a url
in full (ie, bugzilla.mozilla.org) and then hitting enter gives no response.

Comment 1

16 years ago
Same problem with any combobox (?)... e-mail addresses have the same problem in
the mail composer.  trunk build ID: 2003012121.

Comment 2

16 years ago
Confirming over here. Same problem. Pressing enter after an URL doesn't work on 
Linux.

Comment 3

16 years ago
the URL bar is completely broken for me in 22/01 build or Windows NT4 here, so I
guess OS has to be changed to all. I cannot do this (the bug reporter can)
There is something wrong with the KeyEvent.
It does not contain all the properties
(http://lxr.mozilla.org/seamonkey/source/dom/public/idl/events/nsIDOMKeyEvent.idl).

Check the JavaScript Console and you will see a lot of warnings.
This happens also for example when using The Help search.
*** Bug 190080 has been marked as a duplicate of this bug. ***
setting keywords from Bug 190080 (blocker, smoketest)
Severity: normal → blocker
Keywords: smoketest
Regression of bug 91557?
(Assignee)

Comment 8

16 years ago
Taking.
Assignee: hewitt → peterv
OS: Linux → All
Priority: -- → P1
Hardware: PC → All
Target Milestone: --- → mozilla1.3beta
(Assignee)

Comment 9

16 years ago
Backed out part of the fix for bug 91557.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
*** Bug 190109 has been marked as a duplicate of this bug. ***
verified with windows commercial build 2003-01-22-10-trunk
Status: RESOLVED → VERIFIED
*** Bug 190213 has been marked as a duplicate of this bug. ***
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.