When I download new messages I get a freeze of mozilla 1.3a (pop3 protocol).

RESOLVED WORKSFORME

Status

MailNews Core
Networking: POP
--
critical
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Alfredo Cerutti, Assigned: Navin Gupta)

Tracking

({hang})

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212

I've also got poppy (pop3 checker) running to check the account.
Some time it works and doesn't crash but I think that if there's an access in
the same time both the programs hang up. Poppy says authentication failed and
mozilla dies.

The download takes place but mozilla freezes before I can read the message.

poppy: http://www.yoursurfice.com/Content/Poppy/Poppy.htm

Reproducible: Always

Steps to Reproduce:
1. run poppy
2. when it says "you got mail" run mozilla
3. crash when downloading the messages

Actual Results:  
I must run Task manager and kill mozilla.

Expected Results:  
read the message.

theme: crystal-classic

Comment 1

16 years ago
can you  close Mozilla, rename XUL.mfl to XUL .bak (in your profile directory)
and restart Mozilla ?
Keywords: hang
Summary: When I download new messages I get a freeze of mozilla 1.3a (pop3 protocol). → When I download new messages I get a freeze of mozilla 1.3a (pop3 protocol).
I have the same problem with Mozilla 1.4 beta.
I'm using it for 4 days, and today it started to hang.
I'm launching Mozilla, Mail&News, if any mail download starts automaticly
Mozilla hangs. If not i can use Mail&News up to time when i want to see unread
mail. Then it hangs.
I have to kill process.

Deleting XUL.mfl didn't help.
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 195576 has been marked as a duplicate of this bug. ***

Comment 4

15 years ago
My mail is working fine.  When I try to download messages in a newsgroup as soon
as I click on Get Messages, Mozilla 1.4 freezes.  I can still run other apps,
but even if I wait, Moz is gone.  Using Win2K SP4.  This was working on another
machine for me last week.  Same version of s/w.  Tried deleting xul.mfl but it
didn't help.

Thanks.

Comment 5

15 years ago
I am seeing reproducible crash with a particular POP account (may be data
dependent). OS X v1.6b and 1.7b both crash on collecting mail:

Date/Time:  2004-03-29 12:03:37 +1000
OS Version: 10.2.6 (Build 6L60)
Host:       toby.intranet

Command:    mozilla-bin
PID:        526

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

Thread 0 Crashed:
 #0   0x06141a84 in
nsMsgIncomingServer::ConfigureTemporaryReturnReceiptsFilter(nsIMsgFilterList*)
 #1   0x06990cf8 in nsParseNewMailState::Init(nsIMsgFolder*, nsIMsgFolder*,
nsFileSpec&, nsIOFileStream*, nsIMsgWindow*)
 #2   0x0698c444 in nsPop3Sink::BeginMailDelivery(int, nsIMsgWindow*, int*)
 #3   0x06988590 in nsPop3Protocol::GetStat()
 #4   0x0698b2c0 in nsPop3Protocol::ProcessProtocolState(nsIURI*,
nsIInputStream*, unsigned, unsigned)
 #5   0x06146cbc in nsMsgProtocol::OnDataAvailable(nsIRequest*, nsISupports*,
nsIInputStream*, unsigned, unsigned)
 #6   0x0035db60 in nsInputStreamPump::OnStateTransfer()
 #7   0x0035d940 in nsInputStreamPump::OnInputStreamReady(nsIAsyncInputStream*)
 #8   0xefeaa104 in nsInputStreamReadyEvent::EventHandler(PLEvent*)
 #9   0xefe6bd74 in PL_HandleEvent
 #10  0xefe6bc98 in PL_ProcessPendingEvents
 #11  0xefe6c17c in _md_EventReceiverProc
 #12  0x969a2c54 in DispatchEventToHandlers
 #13  0x969a2fbc in SendEventToEventTargetInternal
 #14  0x969a63d0 in SendEventToEventTargetWithOptions
 #15  0x969b2940 in ToolboxEventDispatcherHandler(OpaqueEventHandlerCallRef*,
OpaqueEventRef*, void*)
 #16  0x969a2d0c in DispatchEventToHandlers
 #17  0x969a2fbc in SendEventToEventTargetInternal
 #18  0x969b5494 in SendEventToEventTarget
 #19  0x969b7258 in ToolboxEventDispatcher(OpaqueEventRef*)
 #20  0x969c8740 in CallEventDispatchHook
 #21  0x969b3c90 in TryEventDispatcher
 #22  0x969a4570 in GetOrPeekEvent
 #23  0x969a4330 in GetNextEventMatchingMask
 #24  0x969a8054 in WNEInternal
 #25  0x969adf0c in WaitNextEvent
 #26  0x007de3dc in nsMacMessagePump::GetEvent(EventRecord&)
 #27  0x007de2b8 in nsMacMessagePump::DoMessagePump()
 #28  0x007d22c8 in nsAppShell::Run()
 #29  0x0000b53c in main1(int, char**, nsISupports*)
 #30  0x0000ba88 in main
 #31  0x00008724 in _start
 #32  0x000085a4 in start

I have been able to successfully collect mail from a newly created POP account
(different user name) from same Linux/ipopd server. Changing POP server software
to qpopper had no effect.
Product: MailNews → Core

Comment 6

12 years ago
Araskin: "It's better a long time and many versions since this problem occurred."

--> WFM
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.