unavailable to use russian character encoding in subject line

RESOLVED WORKSFORME

Status

MailNews Core
Composition
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Degi Karayev, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021212

Create new letter, input e-mail address, skip subject, write message itself.
Than try to send letter. Messenger will ask about empty subject line. Try to use
Russian letters - you'll get only symbols like digits and dashes...

Reproducible: Always

Steps to Reproduce:
1. Create new letter
2. input e-mail address
3. skip subject
4. write message itself
5. try to send message
6. on notify try to input Russian into the subject line

Actual Results:  
unable to use Russian character encoding (maybe others too)

Expected Results:  
available to get Russian

Comment 1

15 years ago
WFM OS/2 build 2003012212

Please check up your settings at
Edit->Preferences->Mail & Newsgroups->Composition->Character Coding

(Reporter)

Comment 2

15 years ago
settings at Edit->Preferences->Mail & Newsgroups->Composition->Character Coding
сhecked -> Windows-1251. So problem DO exist.

Comment 3

13 years ago
Degi Karayev, is this bug still a problem for you?  I am seeing the Subject 
header being tagged properly as Windows-1251, when the encoding is set to that 
in the composition window and Cyrillic characters are used.
Moz1.7, TB0.7, Win2K
Summary: unavailable to use russian charachter encoding in subject line → unavailable to use russian character encoding in subject line
(Reporter)

Comment 4

13 years ago
looks like in Mozilla 1.7.2
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040803 problem
solved
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

13 years ago
looks like in Mozilla 1.7.2
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040803 problem
solved

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 6

13 years ago
Reopened to fix resolution.
Degi Karayev, in the future, please use "WorksForMe" unless you can point to a 
specific patch that fixed the problem -- thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.