Plaintext mail contents only "This is a multi-part message in MIME format." as text.

VERIFIED DUPLICATE of bug 168386

Status

MailNews Core
MIME
VERIFIED DUPLICATE of bug 168386
16 years ago
10 years ago

People

(Reporter: Patrick M. Kolla, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

When replying to a HTML mail, I have set Mozilla to ask if I want to send HTML or plain text. I decide on plain text usually. Looking into th 'Sent' folder, a few mails just look like filled into the 'Actual results' field.
(happened also without Enigmail installed)

I have a mail where I can reproduce this - click on reply, cut most of the text, add my own, and send as plain text. Always creates this in the sent folder.

Reproducible: Always

Steps to Reproduce:
1. Click 'Reply' for specific (plain text, but mime with attachment) mail
2. Cut most stuff, add my own
3. Send it.

Actual Results:  
Get this as mail in the sent folder (and this also reaches the receiver):
-----------------------------
From - Wed Jan 22 12:40:53 2003
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00800000
Message-ID: <3E2E8345.6030106@patrick.kolla.de>
Date: Wed, 22 Jan 2003 12:40:53 +0100
From: Spybot-S&D Support <spybotsd@patrick.kolla.de>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130
X-Accept-Language: de, en, en-us, fr, es-es
MIME-Version: 1.0
To: ********* <********@attbi.com>
Subject: Re: Spybot-S&D bug report
References: <**cut**>
In-Reply-To: <**cut**>
X-Enigmail-Version: 0.71.0.0
X-Enigmail-Supports: pgp-inline, pgp-mime
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 8bit

This is a multi-part message in MIME format.
-----------------------------


Expected Results:  
Send the text I wrote instead of this.

Here is the source of the mail I can answer to to reproduce the problem; anonymized and most text cut...

-----------------------------
From - Wed Jan 22 09:51:00 2003
X-UIDL: 1043172096.21526
X-Mozilla-Status: 0003
X-Mozilla-Status2: 10000000
Return-path: <********@attbi.com>
Envelope-to: spybotsd@patrick.kolla.de
Delivery-date: Tue, 21 Jan 2003 19:01:35 +0100
Received: from [204.127.198.38] (helo=rwcrmhc51.attbi.com)
	by mxng08.kundenserver.de with esmtp (Exim 3.35 #1)
	id 18b2iI-0001zo-00
	for spybotsd@patrick.kolla.de; Tue, 21 Jan 2003 19:01:30 +0100
Date: Tue, 21 Jan 2003 18:01:29 +0000 (GMT)
X-Comment: Sending client does not conform to RFC822 minimum requirements
X-Comment: Date has been added by Maillennium
Received: from ********* (**-***-**-**.client.attbi.com[**.***.**.**])
          by rwcrmhc51.attbi.com (rwcrmhc51) with SMTP
          id <**************************>; Tue, 21 Jan 2003 18:01:29 +0000
Message-ID: <***************************************>
From: "********" <*********@attbi.com>
To: <spybotsd@patrick.kolla.de>
Cc: <********@attbi.com>
Subject: Spybot-S&D bug report
MIME-Version: 1.0
Content-Type: multipart/mixed;
	boundary="----=_NextPart_000_0000_01C2C144.D2F5B490"
X-Mailer: Microsoft Outlook Express 6.00.2800.1106
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1106

This is a multi-part message in MIME format.

------=_NextPart_000_0000_01C2C144.D2F5B490
Content-Type: text/plain;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

The skins settings didn't work when I first downloaded the software, and =
after downloading the update skins, this feature still does not allow me =
to customize the look of SB/S&D.

... a lot of text with system report cut here ...

------=_NextPart_000_0000_01C2C144.D2F5B490
Content-Type: application/octet-stream;
	name="guration.ini"
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment;
	filename="guration.ini"

... file contents cut here ...

------=_NextPart_000_0000_01C2C144.D2F5B490--

Comment 1

16 years ago
My Mother-in-law's Mozilla suffers from this whenever anyone sends her an email
with a MIME attachment.

Comment 2

16 years ago
I've gotten this a couple times as well with Mozilla 1.2.1 on Windows 2000.

It does only happen when I am replying to a message with a MIME attachment, and
I choose to send in plain text..  When this happens, I basically have to retype
the whole reply, and choose HTML or Text&HTML instead.

Comment 3

16 years ago
I have encountered this bug in Mozilla 1.2.1 on two different Windows 200
machines and a Redhat Linux box. 

Comment 4

16 years ago
I have been trying to track this for about a month with one user on W2KPro and
Moz1.2.1.  Now I just got one from my folks using XPhome and Moz1.2.1.  In my
case I have not seen it in any reply but ONLY in forwards.

Comment 5

16 years ago
I've this bug too, it was not with former Mozilla version - 1.0 or 1.1 -
I have W2000.
This bug occurs sometimes - I don't know exactly why - when I reply to a HTML
mail with texte only...

Comment 6

16 years ago
I am seeing this problem too -- seems to have cropped up after an upgrade from
1.0 to 1.2.1.

I think inclusion of inline images is triggering it.

Steps to reproduce:

1. Use mouse to paint selection across mozilla.org banner at the top of this page
2. Right click, select Copy from the menu
3. Compose a new e-mail to any recipient (yourself will do)
4. Hit control-v to paste in the message area
5. Press send button
6. Receive mail, only contents of which will be: "This is a multi-part message
in MIME format."
7. Examine 'Sent' box if you keep one and find that the message you sent has the
same contents -- so unfortunately, you possibly just lost data.

This bug seems highly reproducible and cross-platform.  I personally reproduced
these steps on Mozilla 1.2.1 on Solaris and Linux.

Comment 7

16 years ago

*** This bug has been marked as a duplicate of 168386 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Verified dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.