Save Page As... complete missing image

VERIFIED FIXED

Status

Core Graveyard
File Handling
--
blocker
VERIFIED FIXED
15 years ago
2 years ago

People

(Reporter: tracy, Assigned: Samir Gehani)

Tracking

({smoketest})

Trunk
x86
Linux
smoketest

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

832 bytes, patch
John Keiser (jkeiser)
: review+
blizzard
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

15 years ago
seen on linux commercial trunk build 2003-01-22-05-trunk

-following instructions for smoketest B.27:
-goto test URL
-Select File | Save Page As
-in file picker make sure Web Page, Complete is selected in Files of type:
-Save
-then File | Open File and the the mozorg.html file

tested results: the page is missing the mozilla.org header image

expected results: the page is rendered complete with all images
(Reporter)

Comment 1

15 years ago
The image missing from the File Open display is actually present in the saved
mozorg_files folder.  But it is not being picked up by File Open.  I tried file
open of this Saved page with an older version of mozilla and the header is still
missing.
(Reporter)

Comment 2

15 years ago
On windows build 2002-01-22-10-trunk Save Page As doesn't save anything. 

follow steps to test as above:

tested results:  No page is saved at all

expected results:  Page is saved to selected directory with supporting images file

this is worse than what I'm seeing on linux.  If it is believed to be a
different bug please open another.

Comment 3

15 years ago
reassigning to sgehani for triage
Assignee: law → sgehani

Comment 4

15 years ago
This is probably the same problem as in bug 190121.
I tried to view saved page in N7.0 and it didn't work either.
When I looked at source code I found out that there are two attributes
on the image element, width="0" and height="0".
This is obviously wrong.

Comment 5

15 years ago
Created attachment 112327 [details] [diff] [review]
Patch

Send Pixel Units to GetPixelValue, not GetIntValue (which asserts and returns)

Comment 6

15 years ago
I wasn't getting the problem in Comment #2.
(Reporter)

Comment 7

15 years ago
is this the same issue with bug 190121? dupe?

Comment 8

15 years ago
Comment on attachment 112327 [details] [diff] [review]
Patch

Wow, I suck.  Good catch.  I don't see any more of these in nsHTMLValue.cpp.
Attachment #112327 - Flags: review+
Comment on attachment 112327 [details] [diff] [review]
Patch

sr=blizzard
Attachment #112327 - Flags: superreview+

Comment 10

15 years ago
I can confirm that backing out of jkeiser's HTMLValue checkin fixed this bug.
and bug 190121 too.
Comment on attachment 112327 [details] [diff] [review]
Patch

a=roc+moz
Attachment #112327 - Flags: approval1.3b+

Comment 12

15 years ago
checked-in
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Reporter)

Comment 13

15 years ago
verified with linux respin 2003-10-22-14-trunk
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.