After a download alert is displayed, exiting the application results in a crash (@nsCacheService)

RESOLVED DUPLICATE of bug 189779

Status

()

Core
Networking: Cache
--
major
RESOLVED DUPLICATE of bug 189779
16 years ago
15 years ago

People

(Reporter: Chris Petersen, Assigned: gordon)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Build: 2003-01-20-08 trunk
Platform: OS X 10.2.3 and Windows XP
Expected Results: Application should exit gracefully
What I got: Application crash upon exiting

Steps to reproduce:

1) Go to http://www.macupdate.com/info.php/id/10594
2) Control-click (Mac) or right-click (Windows) to get contextual menu to appear
3) Select Save Link Target as. Save file to disk.
4) A alert appears with "macupdate.com"
5) On the Mac , simply press command-Q  to quit the application. On Windows,
bring the browser window to the front first and press control- Q.
6) During the process of exiting , the application crashes.
(Reporter)

Comment 1

16 years ago
Created attachment 112314 [details]
stack trace
(Reporter)

Comment 2

16 years ago
Talkback report under Windows XP:
http://climate.netscape.com/reports/incidenttemplate.cfm?bbid=16483844
(Reporter)

Comment 3

16 years ago
You must get the alert error to reproduce the crash when exiting (for me). The
file you are attempting to save is a dmg file but appears to be sent as text
from their server.
-> Networking:cache (or http ?)
Assignee: blaker → gordon
Component: Download Manager → Networking: Cache
QA Contact: petersen → tever

Comment 5

16 years ago
tempting to blame this on bug 176919 based on the build date... perhaps this is
somehow a duplicate of bug 189779.

Comment 6

15 years ago
Resolving as dupe of bug 189779 due to lack of reply to comment 5. Please reopen
if this does still happen.

*** This bug has been marked as a duplicate of 189779 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.