Multiple windows open if a URL in a 'Drop Drawers' drawer is double-clicked.

RESOLVED WONTFIX

Status

SeaMonkey
General
RESOLVED WONTFIX
15 years ago
11 years ago

People

(Reporter: Michael Graubart, Assigned: asa)

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.3b) Gecko/20030109
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.3b) Gecko/20030109

'Drop Drawers' is a launching utility that can be downloaded from the above
web-site. If a URL is stored in one of its drawers, it should be possible to
visit the relevant web-site by double-clicking on the URL in the drawer. If
Mozilla is not running, this works perfectly well. If, however, Mozilla is
already running, an infinite series of Mozilla windows begins to open, one after
the other, and this can only be stopped by shutting Mozilla down. I reported
this to Sig Software, the makers of Drop Drawers, and the following is from the
reply by Gideon Greenspan, their chief developer (ggreenspan@sigsoftware.com):

'…all Drop Drawers does … is send a single Apple 
Event (it doesn't even wait for the reply). So perhaps you could tell the 
Mozilla team there's a problem with handling GURL/GURL Apple Events'

Mr. Greenspan has asked me to pass back to him anything the Mozilla engineers
may have to say about this.

Reproducible: Always

Steps to Reproduce:
1. Download Drop Drawers 1.6 (for Mac OS 7/8/9) and install it.
2. Open the drawer called 'Web Sites' and double-click on one of the sites
already stored in it, or store one and double-click on it.


Actual Results:  
If Mozilla is not running, it starts up and goes to the site.
If Mozilla is already running, one window after another starts opening and this
continues ('Stop' has no effect) until one shuts Mo`zilla down.

Expected Results:  
In both cases, only one window should have opened and the chosen web-site should
have been accessed.

Mac G3 (old beige tower), OS 9.2.2. Modern theme.
(Reporter)

Comment 1

15 years ago
Just to confirm that this seems to be a Mozilla bug (please see original report,
with quotation from Drop Drawer's programmer) connected with Mozilla's handling
of Apple Events, I tried resetting my choice of default browser (a) to Netscape
4.79, (b) to Internet Explorer 5.1. In neither case did the multiple opening of
windows take place.
(Reporter)

Comment 2

15 years ago
I have found another situation in which a similar malfunction occurs. If ZipIt
2.2 or 2.2.2 is downloaded from <http://www.maczipit.com/> and installed, a
drop-down menu becomes available under 'Help'. The last item in the ZipIt help
contents is 'I have a question that isn't answered here'. If this is clicked,
Mozilla begins to open and close multiple windows.

I am now using Mozilla 2003011508, which is the last relatively bug-free Mac OS
9.x version available.

I tried to attach a compressed copy of ZipIt 2.2, which is a better version for
OS 9.2.2 than ZipIt 2.2.2, but it was too big.
(Reporter)

Comment 3

15 years ago
Further to Additional Comment 2, I omitted to say that, as in the case of 'Drop
Drawers', the malfunction only occurs if Mozilla is already open.
(Reporter)

Comment 4

15 years ago
I have found yet another situation in which a similar malfunction occurs, and a
more commonly-found one. If one receives an e-mail in Outlook Express and it
contains a link to a website and one clicks on it when Mozilla is set as one's
default browser and it is already open, one again gets multiple windows opening
and has to quit Mozilla to stop the process.

If the e-mail is received in Mozilla Mail itself, this does not happen.

I am still using Mozilla 2003011508, which is the last relatively bug-free Mac OS
9.x version available.

Comment 5

15 years ago
Bugs are targeted at mac classic, which is dead. Marking WONTFIX. Please reopen,
if you can reproduce the bug on Mac OS X with 1.5beta or later.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.