After using Ctrl+G to "Find Again" in Bookmarks, pressing Enter launches previously selected bookmark item

VERIFIED DUPLICATE of bug 19015

Status

P3
normal
VERIFIED DUPLICATE of bug 19015
19 years ago
14 years ago

People

(Reporter: jklenk, Assigned: leger)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
This has been happening as far back as I can remember, and it's always really
bothered me (since I greatly prefer the keyboard over the mouse).

1.)  Go into bookmarks.
2.)  Do a single Find (Ctrl+F), using search criteria that will match multiple
bookmarks.  For instance, do a search on "http".
3.)  The first item found will be correctly highlighted and selected (you can
see the dotted outline above and below it).
4.)  Do a Find Again (Ctrl+G).  The next matching bookmark is correctly found
and highlighted.  However, it is *NOT* selected.  You can see that the first
bookmark that was found with the Ctrl+F search still has the dotted outline.

At this point, if you use an up/down arrow key or press Enter (etc...), then
your keyboard input will be acting on the first found bookmark, not the
highlighted one.

This is annoying, because I have to keep switching between keyboard and mouse (I
have to click on the second found bookmark before being able to load it with the
Enter key).

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 1

19 years ago
*** This bug has been marked as a duplicate of 19015 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 2

19 years ago
[bugday] duplicate, read them both, marked verified. looks like submitter
clicked on submit twice.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.