Status

()

Core
Networking: Cookies
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: Kurt Bücherl, Assigned: Darin Fisher)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030122
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030122

Detailed cookie informations are empty in the current nightly build

Reproducible: Always

Steps to Reproduce:
1.Go to a cookie site, pref set to 'ask before storing a cookie'
2.click on 'Show details'
3.fields are empty

Actual Results:  
No cookie information

Expected Results:  
Detailed cookie information should be shown

COuld reproduce it with a clean profile
Confirmed with build 2003012210 on windows XP
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
-> me
Status: NEW → ASSIGNED
Created attachment 112339 [details] [diff] [review]
fix properties file

Apparently, the spaces are not allowed in the .properties file. But why did it
work in my local build?
Attachment #112339 - Flags: superreview?(darin)
Attachment #112339 - Flags: review?(cbiesinger)
Attachment #112339 - Flags: review?(cbiesinger) → review+
(Assignee)

Comment 4

16 years ago
Comment on attachment 112339 [details] [diff] [review]
fix properties file

sr=darin
Attachment #112339 - Flags: superreview?(darin) → superreview+
Comment on attachment 112339 [details] [diff] [review]
fix properties file

Requesting approval for 1.3b. This is a low risk patch, that fixes a quite
visible bug.
Attachment #112339 - Flags: approval1.3b?

Comment 6

16 years ago
The patch in bug 190256 fixes this.

Comment 7

16 years ago
to quote bz in bug 190085 comment 10:
> KaiRo, just thought you'd like to know that spaces used to be fine in those
> places till alecf's recent checkin.... And will be again once bug 190256 is fixed.
> 
> I say still land this patch, but this should make it clear why it worked when
> you tested it before checking in... ;)

I guess the same applies here...
Depends on: 190256

Comment 8

16 years ago
*** Bug 190315 has been marked as a duplicate of this bug. ***

Comment 9

16 years ago
Darin, is this still needed or did the fix for this bug land from  bug 190256 as
RKAa says?
(Assignee)

Comment 10

16 years ago
asa: i'm not sure.  it's possible that that was the real cause of this bug. 
mvl?  what say you?

Comment 11

16 years ago
With 2003012308 it works for me (stringbundle fix is in there).

Comment 12

16 years ago
...and with 2003012208 it does not work, so it seems quite like 190256 really
did fix this.
It works for me too now, so closing this bug.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 14

16 years ago
Still here on linux/2003012408...

Updated

16 years ago
Attachment #112339 - Flags: approval1.3b?
You need to log in before you can comment on or make changes to this bug.