When history is set to 0 days. the Back and Forward buttons do not work

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
16 years ago
5 years ago

People

(Reporter: kaleida, Assigned: radha)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

If the user sets History to 0 days, the browser should save the history in
memory. Then when the browser is closed, the history would be automatically
deleted. Mozilla version 1.2.1 does not maintain any history if the user sets
history to 0 days.

Reproducible: Always

Steps to Reproduce:
1. In the Preferences menu, select "Navigator->History" 
2. Set "Remeber visited pages for the last" to 0 days.
3. Open any Web page and click on any link to open the linked page.
4. Press the Back button to return to the previous page.


Actual Results:  
The Back button is grayed out. Thus, the user cannot even return to the previous
page.

Expected Results:  
 If "Remeber visited pages for the last" to 0 days. Mozilla should keep current
session history in memory. Then both the Back and Forward browser buttons would
work correctly. When the browser is closed, the Mozilla should free the memory,
including the History maintained in memory.
Whiteboard: DUPEME

Updated

16 years ago
Summary: When history is set to 0 days. the Back and Forward buttons do not wik → When history is set to 0 days. the Back and Forward buttons do not work

Comment 1

16 years ago
Duplicate of 126826?  Certainly related.
worksforme, linux trunk build 2003-01-23-05.  Setting the global history to 0
days does not affect session history (and there is no reason why it should).

Are you sure you did not set the session history length pref to 0 as well?

Comment 3

16 years ago
Works for me with WinXP and build 20030123.

Comment 4

16 years ago
WORKSFORME -- Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1; MultiZilla
v1.1.32 final) Gecko/20021130

Comment 5

16 years ago
->History
Assignee: asa → radha
Component: Browser-General → History: Session
QA Contact: asa → claudius

Comment 6

15 years ago
Reporter are you still seeing this?
We've got three WFM's on three different platforms. W/o response i'll mark this
one WFM in a few days.

Comment 7

15 years ago
wfm per comments and nonresponse.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Updated

11 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.