"referenced symbol not found" when starting java applet

RESOLVED DUPLICATE of bug 189461

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 189461
15 years ago
15 years ago

People

(Reporter: Hubert Feyrer, Assigned: Peter Lubczynski)

Tracking

Trunk
x86
SunOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.3b) Gecko/20030119
Build Identifier: Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.3b) Gecko/20030119

Using JDK 1.4.1's libjavaplugin 
(JDK-1.4.1/jre/plugin/i386/ns600/libjavaplugin_oji.so symlinked into
plugins directory), mozilla crashes when starting up a
java applet. about:plugins shows Java support,
but when starting the (any) applet, I get:

ld.so.1: ./mozilla-bin: fatal: relocation error: file
/home1/Solaris/intel/soft/JDK-1.4.1/jre/plugin/i386/ns600/libjavaplugin_oji.so:
symbol GetGlobalServiceManager__16nsServiceManagerPP17nsIServiceManager:
referenced symbol not found
Killed


when trying the "ns610" libjavaplugin_oji.so, mozilla doesn't even
startup.

What is the right Java plugin to use with latest mozilla on 
solaris 8/x86?

Reproducible: Always

Steps to Reproduce:
1. enable Java plugin by symlink (see above)
2. goto any page that has a java applet
3. see mozilla die

Actual Results:  
window closes, process is gone.

Expected Results:  
show the applet? :)

this is with JDK 1.4.1 on Solaris 8/x86.
(Reporter)

Comment 1

15 years ago
the same plugin worls fine with mozilla 1.1 (also on solaris 8/x86).

*** This bug has been marked as a duplicate of 189461 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.