Profile migration broken on Windows

VERIFIED INVALID

Status

--
blocker
VERIFIED INVALID
16 years ago
3 years ago

People

(Reporter: tracy, Assigned: sspitzer)

Tracking

({regression, smoketest})

Trunk
x86
Windows 2000
regression, smoketest

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
seen with windows2k commercial build 2003-01-23-04-trunk

-install and launch the build
-in the profile manager select the migratable profile and start the app

tested results: nothing happens

expexted results:  a dialog pops up asking to convert this profile, click okay,
profile is converted, then the build launches

Comment 1

16 years ago
I just did this with the 2003012105-Trunk Mozilla build without any problems. So
it's a very recent regression.
Keywords: regression

Comment 2

16 years ago
I installed trunk build 20030123-08, w2k, over another installation (yes, I know
I shouldn't do this).
When starting Mozilla, I can select the profile I want and Mozilla launches
without any problem. 
tracy, does this work with the 8am verif build?

Comment 4

16 years ago
I cannot reproduce with the 04 build on XP or 2k- On XP I have multiple profiles
to migrate and choosing one is successful- shows conversions and goes to
Activation pages. On 2k machine the single profile migrates and goes to
Activation pages.  

Updated

16 years ago
QA Contact: ktrina → gbush
taking for now.
Assignee: racham → sspitzer

Comment 6

16 years ago
Is this related to bug 190256, or to GRE stuff?

Comment 7

16 years ago
I get a crash on windows XP trying to launch the latest nightly. I cleared
program directory before installing. Mozilla installed to D:\program
files\mozilla.org\mozilla as specified in the installation. GRE files were
created on my main windows partition. Copying these files to the mozilla
directory on the D drive and the program still doesn't work but no longer
brought up a crash dialog.
I tried 2 cases of migration:

(1) having more than 1 4.x profile so the profile picker came up and the
migration confirm dialog is put up from JS.
(2) having only 1 4.x profile so automigration happens and the confirm dialog is
put up from C++.

Both cases WFM. This was with a Win32 debug tree just pulled and built.
not sure if this is related to string bundle or GRE stuff.

the 04 am build that twalker tested did not have alecf's string bundle fix.

from 01/23/2003 07:48
Status: NEW → ASSIGNED
I think can reproduce with my ns debug bits.

to make it go away, I set USE_LOCAL_GRE=1
I'm getting entry point not found errors, string foo in the xpcom.dll is not 
found.
fwiw, my debug ns and moz bits have this problem with -installer, but go away 
when I set USE_LOCAL_GRE

the 4am opt moz bits work fine, though.
Tracy, is this a similar problem that we discovered the other day?  Can you
remove all registry entries under:

HKEY_CURRENT_USER\Software\mozilla.org

and try again?

ssu has a bug to fix this up.

Comment 14

16 years ago
I was not able to reproduce this bug with today's build.  I installed 4.x to
create a 4.x profile.  After installed today's commercial build, it migrated my
4.x profile then tossed me into the activation dialogs, and eventually the
browser window came up.

I wonder if this bug might be caused by bug 190144.
Please make sure that you're installing the build into a new folder, not ontop
of an older build (at least until bug 190144 is fixed).
so... is this only happening with commercial builds?  Or Mozilla ones too?
according to twalker, mozilla 4am builds too.

just migration (-installer) seems hosed for him, nothing else

for me, 4am mozilla bits are fine.
(Reporter)

Comment 17

16 years ago
marking invalid.  sorry folks.


ssu, please verfify. oh, you left your soda in my cube. 
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 18

16 years ago
just took a look at twalker's machine.  something was messed up with the profile
the browser was trying to migrate.

1) there was no source profile to migrate from
2) there was already a target dir in the mozilla profile directory with lots of
files in it as if it was already migrated
3) the target dir did not have the salted dir in it (very weird)

  The profile in question was already in the mozilla's profile dir, so I'm not
sure why it kept indicating that it still needed to be migrated.  The machine
that this is happening on is a test machine, so it might have gotten messed up
from the many tests that twalker does.

We cleaned it up, created a 4.x profile, installed today's build, and it
migrated the 4.x profile just fine.

closing this bug as invalid.

Comment 19

16 years ago
verified
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.