crash if i close a reply-to/compose mail window quickly - Trunk [@ 0x0000000b]

RESOLVED WORKSFORME

Status

MailNews Core
Composition
--
critical
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Jhe, Assigned: Jean-Francois Ducarroz)

Tracking

({crash, qawanted, topcrash})

Trunk
x86
Linux
crash, qawanted, topcrash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212

If the mail composing window is closed too quickly, mozilla would crash. 

Reproducible: Always

Steps to Reproduce:
1.Open Mailnews
2.Click reply-to or compose
3.Before the window content fully appears, close the window. 

Actual Results:  
crash

Expected Results:  
window closed. No crash

% uname -a :
Linux kingfisher 2.4.18-6mdk #1 Fri Mar 15 02:59:08 CET 2002 i686 unknown
Talkback crash ID :
TB15934321Z

Updated

16 years ago
Keywords: crash, stackwanted
Whiteboard: TB15934321Z

Comment 1

16 years ago
not much of a stack, but here is the incident:
Incident ID 15934321
Stack Signature 0x0000000b f475f2f3
Email Address
Product ID MozillaTrunk
Build ID 2002121217
Trigger Time 2003-01-08 06:04:10
Platform LinuxIntel
Operating System Linux 2.4.18-6mdk
Module
URL visited
User Comments
Trigger Reason SIGSEGV: Segmentation Fault: (signal 11)
Source File Name
Trigger Line No.
Stack Trace
0x0000000b 

Adding topcrash keyword since that stack signature is showing up in the topcrash
list for the MozillaTrunk.  Also adding qawanted to see if QA can reproduce this.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: stackwanted → qawanted, topcrash
Summary: crash if i close a reply-to/compose mail window quickly → crash if i close a reply-to/compose mail window quickly - Trunk [@ 0x0000000b]

Comment 2

16 years ago
Jay: the 0x0000000b stack is thoroughly bogus (bug 176886)
Whiteboard: TB15934321Z

Comment 3

16 years ago
I crash with linux build 1.3a, but current trunk (20030124) is fine.

Jhe: can you try a nightly build or grab 1.3b when it's available?
(Reporter)

Comment 4

16 years ago
I will get 1.3b when it is available.
If have some time, I will try a nightly.
(Reporter)

Comment 5

16 years ago
I have installed the latest nightly:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030127
It seems like the problem do not appear. I have not been able to reproduce it.
If I try a reply-to instead of compose, I can now see the "save message" dialog,
which wasn't the case before. Therefore, I think this is good news.

Jhe.

Comment 6

16 years ago
great!
marking WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
Crash Signature: [@ 0x0000000b]
You need to log in before you can comment on or make changes to this bug.