<script> tag in xml treated like html tag

RESOLVED DUPLICATE of bug 91240

Status

()

Core
XML
RESOLVED DUPLICATE of bug 91240
16 years ago
16 years ago

People

(Reporter: Sean McMurray, Assigned: Heikki Toivonen (remove -bugzilla when emailing directly))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202

I'm sending xml to the browser with a <script> tag, and a <?xsl-stylesheet>
instruction.

The browser does not recognize any xml inside the <script> tag. View source has
sytax highlighting on all xml except within the <script> tag.

I'm guessing that <script> is some reserved tag for Mozilla. It should not be,
within an xml document.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
We really need a testcase. Either a URL or attach here...
And note that viewsource is generally buggy with XML.
(Reporter)

Comment 3

16 years ago
*** Bug 190361 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 4

16 years ago
There isn't really a problem (except with "view source"). Thank you and sorry.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
reopening to dup to the right bug..
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

*** This bug has been marked as a duplicate of 91240 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.