allow menu item doesn't treat domain.com like *.domain.com (unlike in ns7.01)

VERIFIED WORKSFORME

Status

SeaMonkey
Preferences
P2
normal
VERIFIED WORKSFORME
15 years ago
13 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: shliang)

Tracking

Bug Flags:
blocking1.3 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
found using 2003.01.21.10 commercial trunk builds on linux rh8.0 and win2k
(prolly cross-platform).

this seems to occur the first time for fresh profiles. rather strange.

case a
------
1. in the popup windows prefs, select "allow popups".
2. click on "exceptions" button to bring up blacklist dlg.
3. add some sites to blacklist, eg, netscape.com, aol.com, gap.com, etc.
4. save and dismiss exceptions dlg and prefs window.
5. visit a blocked site that you set in step 3. as expected, you'll get a beep
and the notfication icon will appear.
6. select the following menu item: Tools - Popup Manager - Unblock Popups from
this Site. as expected, the notfication icon goes away from the statusbar.
7. open popup windows panel in Prefs, and open the blacklist.

results: the site is still listed in the blacklist. it should be removed.



------- Additional Comments From sairuh@netscape.com 2003-01-21 16:07 ----

er, ignore the "case a" thingie --my second case didn't pan out (so far).



------- Additional Comments From sairuh@netscape.com 2003-01-21 16:47 ----

just discussed this with shuehan over aim: it turns out that the menu item
distinguishes btwn blah.domain.com and domain.com --they're considered unique sites.

this differs from blackbird, where domain.com included *.domain.com variations
when it came to blocking or unblocking sites.



------- Additional Comments From sairuh@netscape.com 2003-01-21 16:48 ----

*** Bug 22025 has been marked as a duplicate of this bug. ***



------- Additional Comments From sairuh@netscape.com 2003-01-21 17:06 ----

this should really be in bugzilla. but, dangnabbit, my move privs have gone poof
again.

shiva, may i have bugscape -> bugzilla move privs again? maybe it disappeared
when bugscape was last updated. (i tried logging out and in again. hm...)



------- Additional Comments From sairuh@netscape.com 2003-01-22 12:18 ----

ah, that's better...

Bug moved to http://bugzilla.mozilla.org.

If the move succeeded, sairuh@netscape.com will receive a mail
containing the number of the new bug in the other database.
If all went well,  please mark this bug verified, and paste
in a link to the new bug. Otherwise, reopen this bug.




------- Additional Comments From sairuh@netscape.com 2003-01-23 12:49 ----

trying again, as the previous move attempt didn't work.

Bug moved to http://bugzilla.mozilla.org.

If the move succeeded, sairuh@netscape.com will receive a mail
containing the number of the new bug in the other database.
If all went well,  please mark this bug verified, and paste
in a link to the new bug. Otherwise, reopen this bug.




------- Bug moved to this database by sairuh@netscape.com 2003-01-23 12:50 -------

This bug previously known as bug 22024 at http://bugscape.nscp.aoltw.net/
http://bugscape.nscp.aoltw.net/show_bug.cgi?id=22024
Originally filed under the Browser product and Popup Blocking component.
Bug depends on bug(s) 22023.

---
Unknown bug field "reporter_accessible" encountered while moving bug
<reporter_accessible> 1 </reporter_accessible>
---
Unknown bug field "cclist_accessible" encountered while moving bug
<cclist_accessible> 1 </cclist_accessible>
Unknown version other in product Browser. Setting version to "1.0 Branch".

(Reporter)

Comment 1

15 years ago
reopening...
Status: RESOLVED → UNCONFIRMED
Component: Browser-General → Preferences
Keywords: nsbeta1
Resolution: MOVED → ---
Version: 1.0 Branch → Trunk
(Reporter)

Comment 2

15 years ago
and confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

15 years ago
repeated the test in comment 0 (the fresh profile remark is irrelevant now) with
2003.02.03.05 trunk bits on linux rh7.2.

it looks like this is limited to using the menu item, Tools - Popup Manager -
Allow Popups from this Site.

if i click on the notification icon in the status bar, this isn't a problem
--the uber site (eg, netscape.com for *.netscape.com sites) is selected for
removal in the blacklist.

if i select Tools - Popup Manager - Manage Popup Permissions, i just run into
bug 190014 comment 7 (no pre-selection in blacklist).
(Reporter)

Updated

15 years ago
Summary: block/unblock menu item doesn't treat domain.com like *.domain.com (unlike in ns7.01) → suppress/allow menu item doesn't treat domain.com like *.domain.com (unlike in ns7.01)
(Reporter)

Comment 4

15 years ago
converse test case:

1. in popup prefs, select "suppress popups" radio button, and click Exceptions.
2. in the resulting whitelist dlg, add the following: netscape.com, resfest.com,
etc...
3. click OK, OK.
4. visit either home.netscape.com or www.resfest.com. as expected, unrequested
popups will appear.
5. look at the Tools - Popup Manager submenu.

expected: Tools - Popup Manager - Suppress Popups from This Site should be enabled.

actual results: Suppress Popups from This Site is disabled; instead Allow Popups
from This Site is enabled.

(again, if i bring up Tools - Popup Manager - Manage Popup Permissions, the
whitelist Exceptions dlg appears. no pre-selection/prefilling due to bug 190014
comment 7, but it's editable.)
(Reporter)

Comment 5

15 years ago
could this be fixed for 1.3final?
Flags: blocking1.3?

Comment 6

15 years ago
annoying but not a 1.3 blocker.
Flags: blocking1.3? → blocking1.3-

Comment 7

15 years ago
Nav triage team: need info.  Shuehan, Sairuh, can you update us with
recommendations based on the recent usability study for popup blocking?  Thanks.
Whiteboard: [need info]
(Reporter)

Comment 8

15 years ago
using a test build from shuehan (from 3/6), i see this happening anymore.

0. no longer have blacklist; only whitelist used now.
1. have blocking ON
2. add to the whitelist ("allow" list) resfest.com
3. save and dismiss list
4. visit www.resfest.com

results: as expected, unreqested popup is allowed from www.resfest.com
(resfest.com is treated as *.resfest.com).

Comment 9

15 years ago
Nav triage team: nsbeta1-  

If patch for test build behavior does not land or is different please nominate
again.
Keywords: nsbeta1 → nsbeta1-
Whiteboard: [need info]
(Reporter)

Comment 10

15 years ago
re comment 8: s/i see this/i don't see this/

anyhow, nsbeta1- is fine (pending patch checkin).
(Reporter)

Comment 11

15 years ago
w4m with 2003.03.27 comm trunk builds.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Summary: suppress/allow menu item doesn't treat domain.com like *.domain.com (unlike in ns7.01) → allow menu item doesn't treat domain.com like *.domain.com (unlike in ns7.01)
(Reporter)

Comment 12

15 years ago
vrfy
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.