<script> tag in xml treated like html tag

VERIFIED DUPLICATE of bug 190330

Status

()

Core
XML
VERIFIED DUPLICATE of bug 190330
15 years ago
15 years ago

People

(Reporter: Sean McMurray, Assigned: Heikki Toivonen (remove -bugzilla when emailing directly))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202

I'm sending xml to the browser with a <script> tag, and a <?xsl-stylesheet>
instruction.

The browser does not recognize any xml inside the <script> tag. View source has
sytax highlighting on all xml except within the <script> tag.

I'm guessing that <script> is some reserved tag for Mozilla. It should not be,
within an xml document.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 190330 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.