MFCEmbed installer crashing during setup

VERIFIED FIXED in mozilla1.4alpha

Status

Core Graveyard
Installer: MFCEmbed
P1
blocker
VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: Charles Rosendahl, Assigned: Sean Su)

Tracking

({regression, topembed+})

Trunk
mozilla1.4alpha
x86
Windows 2000
regression, topembed+
Bug Flags:
blocking1.3 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

28.60 KB, patch
Samir Gehani
: review+
dveditz
: superreview+
dbaron
: approval1.3+
Details | Diff | Splinter Review
(Reporter)

Description

16 years ago
Setup is crashing trying to install mfcembed.  Happens fairly immediately after
pressing the 'install' button.

Updated

16 years ago
Keywords: topembed → topembed+

Comment 1

16 years ago
*** Bug 191142 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 2

16 years ago
Created attachment 113547 [details] [diff] [review]
patch v1.0
(Assignee)

Comment 3

16 years ago
Comment on attachment 113547 [details] [diff] [review]
patch v1.0

Changes to extra.c are only to check to null pointers, nothing more.

Most of the fix is in the installer build process itself.
Attachment #113547 - Flags: superreview?(dveditz)
Attachment #113547 - Flags: review?(sgehani)
(Assignee)

Comment 4

16 years ago
I don't know if this is a 1.3b blocker.  But I'll request it just in case.  The
main changes were to the mfcembed's installer's build process.

The changes to extra.c were only to check for null pointers.

Chak, once this patch is checked in, mfcembed will probably not start up.  I'm
guessing that it's looking for GRE 1.3a's windows regsitry keys, when we're
installing GRE 1.3b now.

I don't know who's the person to fix that.
Status: NEW → ASSIGNED
(Assignee)

Comment 5

16 years ago
tryin again to request 1.3b+ status
Flags: blocking1.3b?

Comment 6

16 years ago
MfcEmbed will look at the registry key based on the current Mozilla version.

Please see the usage of MOZILLA_VERSION at:
http://lxr.mozilla.org/seamonkey/source/embedding/tests/mfcembed/winEmbedFileLocProvider.cpp#205
(Assignee)

Comment 7

16 years ago
Created attachment 113558 [details] [diff] [review]
patch v1.1

new patch with added changes to runapp.bat.  mfcembed installer build script
(makeall.pl) now delivers the updated runapp.bat.  Nothing else changed as
compared to the previous patch.
Attachment #113547 - Attachment is obsolete: true
(Assignee)

Updated

16 years ago
Attachment #113547 - Flags: superreview?(dveditz)
Attachment #113547 - Flags: review?(sgehani)
(Assignee)

Updated

16 years ago
Attachment #113558 - Flags: superreview?(dveditz)
Attachment #113558 - Flags: review?(sgehani)
(Assignee)

Comment 8

16 years ago
forgot to mention that the fix to runapp.bat allows mfcembed to startup now. 
Runapp.bat updates the search path appropriately, then spawns mfcembed.exe.
(Assignee)

Comment 9

16 years ago
talked to chak.  he said that mfcembed is not as important as it once was
because mozilla now works with GRE.

This fix can wait till 1.4a.  removing request for 1.3b.

twalker, chak said that you don't need to smoke test mfcembed till 1.4a.
Flags: blocking1.3b?

Comment 10

16 years ago
Eventhough Mozilla uses the GRE it does not use the Gecko embedding APIs like
MfcEmbed does.

So, we still need to get the MfcEmbed installer fixed soon (1.4a) so that Tracy
can test the embedding builds....thanks

(Assignee)

Updated

16 years ago
Target Milestone: --- → mozilla1.4alpha
(Reporter)

Comment 11

16 years ago
Sean has the patch, and gecko qa really needs this fixed asap to continue buffy,
gre, and gecko api testing.

Need to get this in asap.
Severity: major → blocker
Flags: blocking1.3?
Priority: -- → P1

Updated

16 years ago
Flags: blocking1.3? → blocking1.3-

Comment 12

16 years ago
Comment on attachment 113558 [details] [diff] [review]
patch v1.1

r=sgehani
Attachment #113558 - Flags: review?(sgehani) → review+
Comment on attachment 113558 [details] [diff] [review]
patch v1.1

sr=dveditz
Attachment #113558 - Flags: superreview?(dveditz) → superreview+
(Assignee)

Comment 14

16 years ago
Comment on attachment 113558 [details] [diff] [review]
patch v1.1

This patch mainly fixes up the mfcembed's installer build process (script
files), which has nothing to do with mozilla's build process.

The only part that affects mozilla code is a couple places that checks for null
pointers in the win32 installer code.

Other than that, it's pretty harmless but with a lot of gain for mfcembed.
Attachment #113558 - Flags: approval1.3?
Attachment #113558 - Flags: approval1.3? → approval1.3+
(Assignee)

Comment 15

16 years ago
patch checked in.  closing bug as fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
verified fixed with mfcembed 2003-02-21-05
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.