COL.style.backgroundColor/color not changed in display

VERIFIED DUPLICATE of bug 915

Status

()

Core
Layout: Tables
P3
normal
VERIFIED DUPLICATE of bug 915
18 years ago
18 years ago

People

(Reporter: martin.honnen, Assigned: Pierre Saslawsky)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
When I set
  .style.backgroundColor
  .style.color
for a COL element I get not display change. IE5 does that already.

<BUTTON ONCLICK="var col = document.getElementById('Name');
col.style.backgroundColor = 'lime';">
col 1 background lime
</BUTTON>
<BUTTON ONCLICK="var col = document.getElementById('Name'); col.style.color =
'blue';">
col 1 text blue
</BUTTON>
<BR>
<TABLE>
<CAPTION>
Gods
</CAPTION>
<COL ID="Name">
<COL ID="Home">
<COL ID="Power">
<TR>
<TH>
Name
</TH>
<TH>
Home
</TH>
<TH>
Power
</TH>
</TR>
<TR>
<TD>
Kibo
</TD>
<TD>
www.kibo.com
</TD>
<TD>
42
</TD>
</TR>
<TR>
<TD>
Xibo
</TD>
<TD>
www.xibo.com
</TD>
<TD>
-42
</TD>
</TR>
</TABLE>
(Reporter)

Comment 1

18 years ago
Created attachment 2910 [details]
bug demo

Comment 2

18 years ago
In an attempt to get my bug list in order again, marking all the bugs I have
currently as ASSIGNED.

Updated

18 years ago
Assignee: vidur → karnaze
Status: ASSIGNED → NEW
Component: DOM Level 2 → HTMLTables

Comment 3

18 years ago
This is either a style bug or table bug so changing component and re-assigning

Updated

18 years ago
Assignee: karnaze → pierre

Comment 4

18 years ago
The background color of the column works in "standard" mode only. The forground
color I think is a style problem, so I'm reassigning to Pierre.
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 5

18 years ago
*** This bug has been marked as a duplicate of 915 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 6

18 years ago
[bugday] Verified duplicate. column styles not implemented.
You need to log in before you can comment on or make changes to this bug.