If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mozilla displays the code for this cgi script rather than formatting it properly

RESOLVED INVALID

Status

SeaMonkey
General
RESOLVED INVALID
15 years ago
12 years ago

People

(Reporter: Justin, Assigned: asa)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.0.3705)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.2) Gecko/20021216

The code is displayed for this CGI script ( http://kiamo.com/cgi-bin/AIM.cgi?
display ) rather than formatting it properly.  I am sending the 
header "Content-type:text/html" followed by 2 new lines as directed by the 
specs.  The page works fine in Internet Explorer, but does not work in ANY 
tested versions of Mozilla on Linux or Windows.

Reproducible: Always

Steps to Reproduce:
1. Go to http://kiamo.com/cgi-bin/AIM.cgi?display
Actual Results:  
The site displays code.  It doesn't display the web page like it should.

Expected Results:  
Shown the web page like a web page, not like code.  Internet Explorer works 
just like it should on the page.

We've tried it on many machines running Linux or Windows and using many 
Mozilla builds.  I tried sending more specific header, but it still didn't 
work.  Once again, Internet Explorer displays the site with no problems.
Headers sent by the server:

HTTP/1.1 200 OK
Date: Fri, 24 Jan 2003 06:18:28 GMT
Server: Apache/1.3.26 (Unix) PHP/4.2.2 mod_gzip/1.3.19.1a
<br>E-mail the admin with this error or something...Content-type: text/html
<P>You broke it!  Or rather just caused an error... maybe your stuff was too
long.  (Max: 1024, you: 0)
Connection: close
Content-Type: text/plain


Note that the Content-Type being sent is text/plain (and that the script's
attempt to send it as text/html is munged by some sort of error message).

Given those headers the rendering is correct (and IE's is a well-known bug).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.