Mozilla untruthfully reports successfull delivery of a message

RESOLVED DUPLICATE of bug 158059

Status

--
critical
RESOLVED DUPLICATE of bug 158059
16 years ago
10 years ago

People

(Reporter: patrick.fromberg, Assigned: mscott)

Tracking

({dataloss})

Trunk
x86
Windows 2000
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021211
Build Identifier: Mozilla 1.2 and 1.2.1

When Mozilla uses the SMTP Server smtprelay.t-online.de and the user is not
registered with that server, the server will report Error 421 (I have been told).
But Mozilla reports successfull delivery in this case. The Mail never arrives.

To find out, if the problem was with the smtp server or in Mozilla, I sent a
very huge file. Mozilla reported success after a second, while delivery would
not have been possible in less then half an hour. So the mistake must be in Mozilla.

This was by far the worst bug in Mozi, I ever saw until now!

Reproducible: Always

Steps to Reproduce:
1. Dont be a t-online user registered with the smtprelay.t-online.server
2. Set smtprelay.t-lonline.de as SMTP Server (dont register!)
3. Sent a mail
4. Mail will not be sent, that is ok
5. Mozilla will report successfull delivery of the mail 8-((((

Actual Results:  
I registered again with smtprelay.t-online.de and everything was ok again.

Expected Results:  
Cry instead of smiling.

This problem may do a lot of harm in the next month. The reason is, that many
smtprelay.t-online.de useres will be unregistered automatically because t-online
wants to change the usage conditions of this service. Until now it was a free
service, that you just had to register with. Next month, t-online will charge
2.5,-EUR per month for the service.

Updated

16 years ago
Flags: blocking1.3b?
Keywords: dataloss

Comment 1

16 years ago
dupe of bug 158059

Comment 2

16 years ago
according to Comment #1 . This has been fixed in the trunk.

*** This bug has been marked as a duplicate of 158059 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
Flags: blocking1.3b?
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.