Body text area unresponsive when compiled using --enable-plaintext-editor-only

RESOLVED EXPIRED

Status

--
major
RESOLVED EXPIRED
16 years ago
10 years ago

People

(Reporter: keithm, Assigned: bugzilla)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20030124
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20030124

I Recently just finished upgrading the GTK/Qt libs and the apps that use them. 
When building mozilla, I configure it using the --enable-plaintext-editor-only
flag and all seemed fine until I started to use the mail & news componet.  When
composing a new message or replying to a message the only area that seems to
work correctly is the subject line.  The To: field will let you type, but is
initally empty instead of having the reply address/newsgroup name entered when
replying.  Also the body area cannot be focused on to type a message.

Reproducible: Always

Steps to Reproduce:
1. Compile using lastest released source and use the flag
--enable-plaintext-only-editor
2. Open mail/news window and reply to or create a new message
3. Try to type into the body of the message.
4. If replying, there will also be no quoted text or addresses prefilled, only
the subject is prefilled.

Actual Results:  
Body is unresponsive and items are not prefilled durning a reply

Expected Results:  
Body should work normally and contain any prefilled text.

I'm still not that great of a linux user, so there may be something wrong with
how I compiled the librarys or mozilla.  Here are the stats to all I think may
apply:

GTK 1.2.10
GTK 2.2.0
GLIB 1.2.10
GLIB 2.2.0
Qt 3.1.0
Mozilla 1.3a
GCC 3.2

configure line:
./configure --disable-jsd --disable-installer --disable-xprint
--disable-postscript --enable-xft --disable-debug --disable-logging
--disable-dtd-debug --with-pthreads --with-x
(Reporter)

Comment 1

16 years ago
I rebuilt mozilla again (see if I could get it to run better, was going kinda
slow) and decided to try this flag again to see if there was anything different.
 Nothing really changed in it, but I have the debugging enabled this time so
here is what it says when I open a mail composer window:

------------------------------------------------------------------------------------------------------
JavaScript error: 
chrome://help/content/contextHelp.js line 1: redeclaration of const MOZ_HELP_URI

JavaScript error: 
chrome://editor/content/editorUtilities.js line 1: redeclaration of const XUL_NS

WEBSHELL+ = 6
[nsIMsgIdentity: id1],[nsIMsgIdentity: id2],[nsIMsgIdentity:
id3],[nsIMsgIdentity: id4],[nsIMsgIdentity: id6]
+++ nsGenericModule nsEditorModule: unable to create factory for
{ed0244e0-c144-11d2-8f4c-006008159b0c}
###!!! ASSERTION: Factory creation failed: 'NS_SUCCEEDED(rv)', file
nsNativeComponentLoader.cpp, line 152
Break: at file nsNativeComponentLoader.cpp, line 152
                                Init    Incrm   Resze   Style   Dirty   Total
------------------------------------------------------------------------------
      nsBoxToBlockAdaptor       1       0       1       0       0       2
         nsGfxScrollFrame       1       0       2       0       0       3
            ViewportFrame       1       0       2       0       0       3
              CanvasFrame       1       0       1       0       0       2
             nsBlockFrame       2       0       2       0       0       4
               nsBoxFrame       1       0       2       0       0       3
             Grand Totals       7       0       10      0       0       17
+++ nsGenericModule nsEditorModule: unable to create factory for
{ed0244e0-c144-11d2-8f4c-006008159b0c}
###!!! ASSERTION: Factory creation failed: 'NS_SUCCEEDED(rv)', file
nsNativeComponentLoader.cpp, line 152
Break: at file nsNativeComponentLoader.cpp, line 152
                                Init    Incrm   Resze   Style   Dirty   Total
------------------------------------------------------------------------------
      nsBoxToBlockAdaptor       1       0       0       0       0       1
         nsGfxScrollFrame       1       0       0       0       0       1
            ViewportFrame       1       0       0       0       0       1
              CanvasFrame       1       0       0       0       0       1
             nsBlockFrame       2       0       0       0       0       2
               nsBoxFrame       1       0       0       0       0       1
             Grand Totals       7       0       0       0       0       7
+++ nsGenericModule nsEditorModule: unable to create factory for
{ed0244e0-c144-11d2-8f4c-006008159b0c}
###!!! ASSERTION: Factory creation failed: 'NS_SUCCEEDED(rv)', file
nsNativeComponentLoader.cpp, line 152
Break: at file nsNativeComponentLoader.cpp, line 152
                                Init    Incrm   Resze   Style   Dirty   Total
------------------------------------------------------------------------------
      nsBoxToBlockAdaptor       1       0       0       0       0       1
         nsGfxScrollFrame       1       0       0       0       0       1
            ViewportFrame       1       0       0       0       0       1
              CanvasFrame       1       0       0       0       0       1
             nsBlockFrame       2       0       0       0       0       2
               nsBoxFrame       1       0       0       0       0       1
             Grand Totals       7       0       0       0       0       7
+++ nsGenericModule nsEditorModule: unable to create factory for
{ed0244e0-c144-11d2-8f4c-006008159b0c}
###!!! ASSERTION: Factory creation failed: 'NS_SUCCEEDED(rv)', file
nsNativeComponentLoader.cpp, line 152
Break: at file nsNativeComponentLoader.cpp, line 152
                                Init    Incrm   Resze   Style   Dirty   Total
------------------------------------------------------------------------------
      nsBoxToBlockAdaptor       1       0       0       0       0       1
         nsGfxScrollFrame       1       0       0       0       0       1
            ViewportFrame       1       0       0       0       0       1
              CanvasFrame       1       0       0       0       0       1
             nsBlockFrame       2       0       0       0       0       2
               nsBoxFrame       1       0       0       0       0       1
             Grand Totals       7       0       0       0       0       7
+++ nsGenericModule nsEditorModule: unable to create factory for
{ed0244e0-c144-11d2-8f4c-006008159b0c}
###!!! ASSERTION: Factory creation failed: 'NS_SUCCEEDED(rv)', file
nsNativeComponentLoader.cpp, line 152
Break: at file nsNativeComponentLoader.cpp, line 152
Product: MailNews → Core
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → EXPIRED
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.