Help buttons in Account Settings pointing to wrong location in Help

VERIFIED FIXED in mozilla1.4alpha

Status

SeaMonkey
MailNews: Message Display
VERIFIED FIXED
15 years ago
13 years ago

People

(Reporter: robinf, Assigned: Sean Su)

Tracking

Trunk
mozilla1.4alpha
All
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2])

Attachments

(1 attachment, 1 obsolete attachment)

2.81 KB, patch
dmose
: review+
jag (Peter Annema)
: superreview+
(not reading, please use seth@sspitzer.org instead)
: approval1.4b+
Details | Diff | Splinter Review
(Reporter)

Description

15 years ago
Win 2K Commercial trunk Build ID 2003012408:

For IMAP, POP, and News Offline & Disk Space settings in Account Settings, the
Help button in each of these three panels points to the wrong location in Help.

Steps to reproduce:
1. Open Mail/News Account Settings.
2. Select any one of the following:
-Offline & Disk Space for IMAP account
-Offline & Disk Space for News account
-Disk Space for POP account
3. Click Help button.
Actual results: Help window opens to "Setting Up Your Accounts for Working Offline"

Expected results:
-Offline & Disk Space for IMAP account: should point to help topic "Offline and
Disk Space Settings (IMAP)"
-Offline & Disk Space for News account: should point to help topic "Offline and
Disk Space Settings (News)"
--Disk Space for POP account: should point to help topic "Disk Space Settings (POP)"

Here's how to make the Help button in each panel point to the right place:

Account Settings panel for Offline & Disk Space for IMAP account--
Help button context info:
 <rdf:li> <rdf:Description ID="mail_offline_imap" nc:name="IMAP" 
nc:link="chrome://help/locale/mail_help.html#OFFLINE_IMAP"/> </rdf:li>

Account Settings panel for Offline & Disk Space for News account--
Help button context info:
 <rdf:li> <rdf:Description ID="mail_offline_nntp" nc:name="News" 
nc:link="chrome://help/locale/mail_help.html#OFFLINE_NEWS"/> </rdf:li>

Account Settings panel for Disk Space for POP account--
Help button context info:
 <rdf:li> <rdf:Description ID="mail_offline_pop3" nc:name="POP" 
nc:link="chrome://help/locale/mail_help.html#OFFLINE_POP"/> </rdf:li>

nominating for next release

Comment 1

15 years ago
these are documentation issues, not Help browser issues
Assignee: sspitzer → rudman
Component: Help → User
Product: Browser → Documentation
QA Contact: tpreston → rudman
Hardware: PC → All
Version: Trunk → unspecified
(Reporter)

Comment 2

15 years ago
This is a regression, possibly related to the Help button code in the Account
Settings dialog for these options. The help Description IDs already exist in the
help TOC (help-toc.rdf) and content (mail_help.html). 

Re-assigning to Seth for the fix.
Assignee: rudman → sspitzer
(Reporter)

Comment 3

15 years ago
changing product to MailNews.
Component: User → Mail Window Front End
Product: Documentation → MailNews
Target Milestone: --- → mozilla1.3final
Version: unspecified → Trunk

Comment 4

15 years ago
Mail triage team: nsbeta1+/adt2
Assignee: sspitzer → ssu
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt2]
(Assignee)

Updated

15 years ago
Status: NEW → ASSIGNED
Target Milestone: mozilla1.3final → mozilla1.4alpha
(Assignee)

Comment 5

15 years ago
Created attachment 121505 [details] [diff] [review]
patch v1.0
(Assignee)

Comment 6

15 years ago
Created attachment 121508 [details] [diff] [review]
patch v1.1

The problem is that the logic to build the correct help tag, depending on which
type of account pref the user is getting help for, is not reached because it's
keying off of "mail" instead of "mail" || "mail-offline-accounts".
Attachment #121505 - Attachment is obsolete: true
(Assignee)

Updated

15 years ago
Attachment #121508 - Flags: superreview?(jaggernaut)
Attachment #121508 - Flags: review?(cavin)

Comment 7

15 years ago
Comment on attachment 121508 [details] [diff] [review]
patch v1.1

sr=jag
Attachment #121508 - Flags: superreview?(jaggernaut) → superreview+

Comment 8

15 years ago
Comment on attachment 121508 [details] [diff] [review]
patch v1.1

r=dmose
Attachment #121508 - Flags: review?(cavin) → review+
(Assignee)

Comment 9

15 years ago
Comment on attachment 121508 [details] [diff] [review]
patch v1.1

trivial patch. not risky.
Attachment #121508 - Flags: approval1.4b?
Comment on attachment 121508 [details] [diff] [review]
patch v1.1

a=sspitzer
Attachment #121508 - Flags: approval1.4b? → approval1.4b+
(Assignee)

Comment 11

15 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 12

15 years ago
Trunk build 2003-05-22: Mac 10.1.5, WinMe
Verified Fixed.

I changed qa contact from Rudman to nbaca. I hope that's ok.
Status: RESOLVED → VERIFIED
QA Contact: rudman → nbaca
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.