Closed Bug 190550 Opened 17 years ago Closed 17 years ago

Option to disable link outlines when using mouse

Categories

(Core :: CSS Parsing and Computation, enhancement)

enhancement
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: bugzilla, Assigned: dbaron)

References

Details

(Whiteboard: WONTFIX?)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212

There should be an option to disable outlining links when they are clicked with
the mouse. The dotted outline is helpful for keyboard navigation, but can be
visually distracting when using the mouse, especially if the link does not cause
a screen redraw (which means the outline will remain visible until the user
clicks elsewhere).

Reproducible: Always

Steps to Reproduce:
this is slightly different from bug 32818 (which is about a pref to completely
disable the outlines, not just when using the mouse).  See also bug 63962.
Assignee: kmcclusk → dbaron
URL: (any)
Status: UNCONFIRMED → NEW
Component: GFX → Style System
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All
Summary: REQUEST: Option to disable link outlines when using mouse → Option to disable link outlines when using mouse
Whiteboard: WONTFIX?
We already have an option. Go into userContent.css and add:

   :focus:hover { -moz-outline: none; }
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → WORKSFORME
I know. There's a lot of things you can change by editing the stylesheets. But that is hardly an "option" for normal users.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
"Normal users" don't worry about this type of thing.  ->WONTFIX.
Status: REOPENED → RESOLVED
Closed: 17 years ago17 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 409703
Duplicate of this bug: 401446
You need to log in before you can comment on or make changes to this bug.