Closed Bug 190576 Opened 17 years ago Closed 14 years ago

document.writelns confuse parser line numbers

Categories

(Core :: DOM: HTML Parser, defect, P3)

1.0 Branch
x86
All
defect

Tracking

()

RESOLVED FIXED
mozilla1.4beta

People

(Reporter: rginda, Unassigned)

References

Details

Attachments

(1 file)

Load the attached testcase and you'll see something along th lines of
Error ``SyntaxError: missing ; before statement'' [xs] in file
``file:///home/rginda/src/HTML/tests/random.html'', line 15, character 7.

in the JS console.  The problem is that the error itself is actually on line 12.
 If you change the document.writelns to document.write, the line numbers are
correct.
Attached file testcase
it turns out that it's not *just* document.writeln, but any newline written to
the document from script.  If you change the document.writelns to
document.writes, and add a "\n" to the end of every string, you end up with the
same problem.
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla1.4beta
Version: Trunk → 1.0 Branch
This bug is fixed by the patch in bug 307797.
Assignee: harishd → parser
Status: ASSIGNED → NEW
Depends on: 307797
QA Contact: moied → mrbkap
This should be fixed by the checkin for bug 307797.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.