XPConnect error when closing tab

RESOLVED DUPLICATE of bug 184363

Status

SeaMonkey
Tabbed Browser
--
major
RESOLVED DUPLICATE of bug 184363
15 years ago
10 years ago

People

(Reporter: Olivier Cahagne, Assigned: jag (Peter Annema))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
Linux build compiled from CVS 20030125.

Steps to reproduce:
1. Load URL http://www.mozilla.org/
2. Ctrl-T to open new tab,
3. Load http://www.rue-montgallet.com/ in new tab,
4. Once loaded, close the new tab either with Ctrl-W or clicking on the "X".
5. the following error shows in JavaScript console:

************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "'[JavaScript Error: "window._content has no properties" {file:
"chrome://global/content/charsetOverlay.js" line: 218}]' when calling method:
[nsIDOMEventListener::handleEvent]"  nsresult: "0x80570021
(NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame ::
chrome://global/content/bindings/tabbrowser.xml#tabbrowser.removeTab() ::
removeTab :: line 62"  data: yes]
************************************************************
************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "'[JavaScript Error: "event.originalTarget has no properties"
{file: "chrome://navigator/content/navigator.js" line: 243}]' when calling
method: [nsIDOMEventListener::handleEvent]"  nsresult: "0x80570021
(NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame ::
chrome://global/content/bindings/tabbrowser.xml#tabbrowser.removeTab() ::
removeTab :: line 62"  data: yes]
************************************************************

Can it be related to the 7 crash I got yesterday with build 20030124 on Linux
when closing tabs ? TB16571493H, TB16586394Q.
(Reporter)

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 184363 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.