area does not have onmouseover event

VERIFIED DUPLICATE of bug 109445

Status

()

Core
DOM: Events
VERIFIED DUPLICATE of bug 109445
15 years ago
15 years ago

People

(Reporter: SvendTofte, Assigned: saari (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME, URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030117
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030117

area tag in a image map does not fire onmouseover event. does fire onclick.
is this by design, or a bug? I could not find anything else on this. so here goes.

Reproducible: Always

Steps to Reproduce:
1. go to site
2. mouse over red/green box
3. confirm that nothing happens

Actual Results:  
nothing

Expected Results:  
shown an alert box, containing either red/green
Whiteboard: DUPEME

Comment 1

15 years ago
This bug is invalid, I think. This map does not have name attribute
(http://www.w3.org/TR/1999/REC-html401-19991224/struct/objects.html#h-13.6):

  name        CDATA          #REQUIRED -- for reference by usemap --

So this example should be fixed (<map id="mymap" name="mymap">). 
(Reporter)

Comment 2

15 years ago
what you linked, state that map does have a map attribute. but the link is to 
the html 4.0 TR. the document is written in xhtml. where name is illegal, and as 
such, I use id:




http://www.w3.org/TR/xhtml1/#h-4.10




(the html validates, and, I think correct)




anyway, onmousemove works, and onmouseout doesn't. (yes I know, new bug report, 
well, if this is confirmed, I'll file the onmouseout)

Comment 3

15 years ago
Oh, thanks, I miss XML part. You could consult bug 109445 about this stuff.

*** This bug has been marked as a duplicate of 109445 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

15 years ago
well, I didn't know, that turning the page into valid XHTML actually ran into 
another bug. I changed the map and gave it a name, and it now works again.




but it doesn't change that some events dont fire. maybe it's related to the 
other, but I think it's distinctly different. anyway, I added an onmousemove 
event to the green area, and that fires. while the onmouseover still does not.
(Reporter)

Comment 5

15 years ago
I produced a new test case, html strict:




http://home.svendtofte.com/misc/mozillamap/index2.html




the bug as originally reported, is still in effect.

Comment 6

15 years ago
Well, there is another bug 110072 (onMouseOver/onMouseOut event problems with
image maps). Seems, that you second example duped this one.
(Reporter)

Comment 7

15 years ago
you are correct :)

Comment 8

15 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.