nypost.com - only about 1/2 of the page is rendered

VERIFIED WORKSFORME

Status

Tech Evangelism Graveyard
English US
VERIFIED WORKSFORME
16 years ago
3 years ago

People

(Reporter: Paul Constantine, Assigned: Susie Wyshak)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20030113 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20030113 Chimera/0.6+

This started happening 2-3 days ago. The full page DOES render in Safari and IE.
The problem shows itslef in Chimera (Build ID: 2003011304) and Netscape 7.0.1,
indicating an issue with the Gecko engine.

Reproducible: Always

Steps to Reproduce:
1. load URL
Actual Results:  
only about 1/3 to 1/2 of the page renders

Expected Results:  
render the entire page

Comment 1

16 years ago
Here's what's happening here as best as I can figure out... The page in question
is pulling in some external JavaScript via a <script> source, specifically
http://209.10.98.177/RealMedia/ads/adstream_mjx.ads/www.nypost.com/index.shtml/11234567890@Top,Top1,TopRight,Left1,Left3,Right,Right1,Right2,BottomLeft,Bottom,BottomRight,Bottom1,Bottom2,Bottom3,Middle1,Middle2,Middle3,x01,x02,x03?
is the source being pulled.

On lines 124-130 of the aforementioned source we find the following:
document.write ('</script><noscript><a\n');
document.write (' href=');
document.write ("'");
document.write ('http://s0b.bluestreak.com/ix.e?hr&s=139952');
document.write ("'");
document.write ('\n');
document.write (' target=_top><img src=');

This appears to be the source of our problems as the string 
"href='http://s0b.bluestreak.com/ix.e?hr&s=139952' target=_top>"
Is being output as text on the webpage (and everthing after that is broken).
If you condense the above commands into a single document.write, Mozilla does
the right thing, but for some reason breaking it into separate document.writes
is confusing Mozilla.
Component: Page Layout → JavaScript Engine
Product: Chimera → Browser
Version: unspecified → Trunk

Comment 2

16 years ago
This is not a JavaScript Engine bug. Reassigning to Tech Evangelism.
The analysis by kaldari@onyxsys.net above explains what happened.
Web authors must never do 

                    document.write('</script> ...')
but this instead:   document.write('<\/script>...')


If they fail to escape the end-script tag, the HTML parser sees it
and closes the script right there. None of the following document.writes()
will then execute. It is a coding error by the ad authors.

I don't see the problem at the site today, however. Paul: do you 
still see it? If not, you can resolve this bug as WORKSFORME -
Assignee: bryner → susiew
Component: JavaScript Engine → US General
Product: Browser → Tech Evangelism
QA Contact: winnie → zach
Version: Trunk → unspecified

Updated

16 years ago
Summary: only about 1/2 of the page is rendered → nypost.com - only about 1/2 of the page is rendered
(Reporter)

Comment 3

16 years ago
The problem/issue now seems to be gone (for the time being). But it does raise
an issue; following the "rules" too strictly means that Chimera may not render
pages that other browsers will render, leading to an incorrect assumption that
the strict interpreter is at fault. I DO realize and appreciate that there IS a
conundrum here. Thanks for the responses.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 4

15 years ago
v
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.