Save (image or page) fails if filename or path contains a char with ascii>127

RESOLVED DUPLICATE of bug 189301

Status

--
major
RESOLVED DUPLICATE of bug 189301
16 years ago
14 years ago

People

(Reporter: fredrikv, Assigned: asa)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030119
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030119

Saving something (file, image or a page - both "html only" and "complete") fails
when the path or filename contains a character not in basic ascii.

"Not in basic ascii" in this case means with an ascii code > 127, as far as I
can tell. This includes all national characters I have tried, including å
(å or "aring" in html) é (é or "eacute") and € (€ or "euro").

Reproducible with HTTP and FTP.

Reproducible: Always

Steps to Reproduce:
1. Find something to save. The Mozilla logo for example.
2. Save it to a folder or filename that contains a character not in ascii<127.
"Mädchen" (with two dots over the 'a') for example.


Actual Results:  
Nothing is saved.
No error is indicated.
The only hint that it didn't work is that the "saving..." popups doesn't popup.

Expected Results:  
The file should have been saved... (Surprise)

Some North American users might think that filing this as a "major" bug is
wrong. However, all users working on non-english systems will most likely
encounter it. For small files, there is basically no sign of failure and the
behaviour seems unpredictable.

Best matches I find are bugs 166268 and 182023.

Comment 1

16 years ago
Resolving as dup of bug 189301. Please add comment if this isn't fixed in builds
later than Jan 21st.

*** This bug has been marked as a duplicate of 189301 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Summary: Save (image or page) fails if filename or path contains a char with ascii>127 → Save (image or page) fails if filename or path contains a char with ascii>127
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.