valgrind warnings in nsCSSRendering::FillPolygon

VERIFIED DUPLICATE of bug 189723

Status

()

--
minor
VERIFIED DUPLICATE of bug 189723
16 years ago
11 years ago

People

(Reporter: dbaron, Assigned: dbaron)

Tracking

({valgrind})

Trunk
mozilla1.4alpha
x86
Linux
valgrind
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Valgrind spits out a lot of:

==16525== Conditional jump or move depends on uninitialised value(s)
==16525==    at 0x469487DC: nsCSSRendering::FillPolygon(nsIRenderingContext&,
nsPoint const*, int, nsRect*)
(/builds2/clean3/mozilla/layout/html/style/src/nsCSSRendering.cpp:244)

which can be fixed, I think, by checking that GetPenMode succeeded.
Status: NEW → ASSIGNED
Whiteboard: [patch]
Target Milestone: --- → mozilla1.4alpha

Comment 2

16 years ago
identical patch in dupe "[valgrind] Use of uninitialized value in
nsCSSRendering::FillPolygon"

*** This bug has been marked as a duplicate of 189723 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
Whiteboard: [patch]
Keywords: valgrind
You need to log in before you can comment on or make changes to this bug.