Type ahead crashes Phoenix when hitting backspace

VERIFIED DUPLICATE of bug 190755

Status

()

VERIFIED DUPLICATE of bug 190755
16 years ago
16 years ago

People

(Reporter: bugzilla, Assigned: hewitt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20030125 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20030125 Phoenix/0.5

Go onto any website
type '/' to start type ahead
type any letter
now hit backspace
this crashes phoenix in win 98se for me

Reproducible: Always

Steps to Reproduce:
1. Goto any website
2. Turn on type ahead ('/')
3. Type a letter
4. hit backspace

Actual Results:  
Phoenix crashes completely

Expected Results:  
Not crash ;)
(Reporter)

Comment 1

16 years ago
Here is the system dump...

PHOENIX caused an invalid page fault in
module PHOENIX.EXE at 019f:008389d9.
Registers:
EAX=00000000 CS=019f EIP=008389d9 EFLGS=00010206
EBX=00000000 SS=01a7 ESP=00dde844 EBP=00dde87c
ECX=02a27040 DS=01a7 ESI=00f15dd0 FS=0ccf
EDX=00000001 ES=01a7 EDI=00f15e7c GS=0000
Bytes at CS:EIP:
8b 03 53 ff 50 40 8b 86 d0 00 00 00 50 8b 08 ff 
Stack dump:
00000000 022afc98 00f15dd4 00000000 022afc90 008fff24 00dde87c 00dde8b4 10049fb8
008fff24 00dde87c 00f15dd4 00dde8cc 00838893 00dde8cc 008388a6 

Comment 2

16 years ago
Confirmed on 20030125 Linux. This is a new/regression bug since bug 189228 was
fixed. Related, but not nearly as severe, autostart has been disabled by
default; see bug 190468.

-->New
-->All OS
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 98 → All

Comment 3

16 years ago
This seems to have been fixed sometime on the 25th... The 20030126 Linux build
is definitely free of the bug (it now beeps at you once when you backspace away
everything).

Unfortunately I can't find a checkin that would fix this, so marking as WFM.

-->WORKSFORME

Reporter: if you still see this bug on the 20030126 Win32 build (which is now
available) then reopen as a Windows-only bug.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 4

16 years ago
Reopening. This has to be the strangest bug in the world. The pref I added to my
user.js fixed it; I just tried on a new profile and sure enough Phoenix crashes.

See bug 190468 to "fix" two problems at once. Sorry for the bugspam. Like I
said, what a strange bug.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 5

16 years ago

*** This bug has been marked as a duplicate of 190755 ***
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 6

16 years ago
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.