choosing "Preferences..." form menu crashes mozilla 1.2.1

VERIFIED DUPLICATE of bug 169777

Status

()

Core
Preferences: Backend
--
critical
VERIFIED DUPLICATE of bug 169777
15 years ago
15 years ago

People

(Reporter: Philipp Ringli, Assigned: Brian Nesse (gone))

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2.1) Gecko/20021130

this is the crash dump:

**********

Date/Time:  2003-01-26 12:25:18 +0100
OS Version: 10.2.3 (Build 6G30)
Host:       cmyks-TI-OSX.local.

Command:    Mozilla
PID:        584

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

Thread 0 Crashed:
 #0   0x00312544 in nsString::Adopt(wchar_t *, int)
 #1   0x0250fe88 in Deserialize__18nsXULPrototypeTextFP20nsIObjectInputStreamP16ns
 #2   0x0250ea94 in Deserialize__21nsXULPrototypeElementFP20nsIObjectInputStreamP1
 #3   0x024dc840 in nsXULPrototypeDocument::Read(nsIObjectInputStream *)
 #4   0x024d760c in GetPrototype__19nsXULPrototypeCacheFP6nsIURIPP23nsIXULPrototyp
 #5   0x024cef54 in 0x24cef54
 #6   0x024c0c30 in nsXULDocument::EndLoad(void)
 #7   0x024b5008 in XULContentSinkImpl::DidBuildModel(int)
 #8   0x02a8bda4 in nsExpatDriver::DidBuildModel(unsigned int, int, nsIParser *,
nsIContentSink *)
 #9   0x02a70830 in nsParser::DidBuildModel(unsigned int)
 #10  0x02a71ce4 in nsParser::ResumeParse(int, int, int)
 #11  0x02a742d8 in nsParser::OnStopRequest(nsIRequest *, nsISupports *,
unsigned int)
 #12  0x0209dae4 in nsJARChannel::OnStopRequest(nsIRequest *, nsISupports *,
unsigned int)
 #13  0x020b827c in nsOnStopRequestEvent::HandleEvent(void)
 #14  0x020b7720 in nsARequestObserverEvent::HandlePLEvent(PLEvent *)
 #15  0x002d4de0 in PL_HandleEvent
 #16  0x002d4c4c in PL_ProcessPendingEvents
 #17  0x0027c7ec in nsEventQueueImpl::ProcessPendingEvents(void)
 #18  0x028b5e7c in nsMacNSPREventQueueHandler::ProcessPLEventQueue(void)
 #19  0x028b5d20 in nsMacNSPREventQueueHandler::RepeatAction(EventRecord const &)
 #20  0x01efcb14 in Repeater::DoRepeaters(EventRecord const &)
 #21  0x028cc728 in nsMacMessagePump::DispatchEvent(int, EventRecord *)
 #22  0x028cc460 in nsMacMessagePump::DoMessagePump(void)
 #23  0x028cbd6c in nsAppShell::Run(void)
 #24  0x0288b24c in nsAppShellService::Run(void)
 #25  0x001a52a0 in main1(int, char **, nsISupports *)
 #26  0x001a5cfc in main

Thread 1:
 #0   0x9000514c in syscall
 #1   0x90515d6c in BSD_waitevent
 #2   0x9051573c in CarbonSelectThreadFunc
 #3   0x90020d48 in _pthread_body

Thread 2:
 #0   0x9003eaa8 in semaphore_wait_signal_trap
 #1   0x9003e8c4 in _pthread_cond_wait
 #2   0x9051dc30 in CarbonOperationThreadFunc
 #3   0x90020d48 in _pthread_body

Thread 3:
 #0   0x90042688 in semaphore_timedwait_signal_trap
 #1   0x9003e8b4 in _pthread_cond_wait
 #2   0x90233384 in TSWaitOnSemaphoreCommon
 #3   0x9023c170 in TimerThread
 #4   0x90020d48 in _pthread_body

Thread 4:
 #0   0x9003eaa8 in semaphore_wait_signal_trap
 #1   0x9003e8c4 in _pthread_cond_wait
 #2   0x90233368 in TSWaitOnSemaphoreCommon
 #3   0x90248a10 in AsyncFileThread(void*)
 #4   0x90020d48 in _pthread_body

PPC Thread State:
  srr0: 0x00312544 srr1: 0x0000f030                vrsave: 0x00000000
   xer: 0x20000000   lr: 0x00312524  ctr: 0x00312500   mq: 0x00000000
    r0: 0x00312524   r1: 0xbfffeeb0   r2: 0x003d4000   r3: 0x00000000
    r4: 0x00000000   r5: 0xffffffff   r6: 0x00000000   r7: 0x00000000
    r8: 0x001dff43   r9: 0x00000000  r10: 0x001dff43  r11: 0x001dff43
   r12: 0x003d34f4  r13: 0x00000000  r14: 0x00000000  r15: 0x03cfbf60
   r16: 0x02e5a490  r17: 0x03d30070  r18: 0x03d30a10  r19: 0x03d300f0
   r20: 0x00000002  r21: 0x80004005  r22: 0x03d2d5c0  r23: 0xbfffef98
   r24: 0xbfffefa0  r25: 0x026e436c  r26: 0x003e69b0  r27: 0x003e6588
   r28: 0x026b21b0  r29: 0x03d2d5cc  r30: 0x00000000  r31: 0xffffffff

Reproducible: Always

Steps to Reproduce:
1. choose "Preferences..."

Actual Results:  
mozilla crashes.

Expected Results:  
display preferences window.

i deleted the mozilla prefs from /Users/UserName/Preferences/ trying to solve
the problem. no luck.

org.mozilla.navigator.plist
org.mozilla.Mozilla.plist
Mozilla Registry

Comment 1

15 years ago
Does removing (or renaming) the 'XUL.mfl' or 'XUL FastLoad File' helps ?
(Reporter)

Comment 2

15 years ago
yes! renaming/removing the file 'XUL FastLoad File' helped.
but what would be interesting to know is, why did it happen?
thank you for your help!

Comment 3

15 years ago
likely due to XUL fastload corruption.

*** This bug has been marked as a duplicate of 169777 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
v dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.