No return of validation-results from html-validator

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: RainerBielefeldNG, Assigned: asa)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
I see a problem with build 20030121 and 20030126
No problem with Mozilla/5.0 (Windows; U; Win98; de-AT; rv:1.3b) Gecko/20030115

Steps to reproduce:
1. goto http://validator.w3.org/file-upload.html
2. select only Verbose Output
   (but problem also happens with other preferences)
3. browse for a file on your PD, I tried with 
  D:\Eigene Dateien\INTERNET\Internetauftritt\Bielefeld__Buss_oHG\shop\shop.html
4. select file
5. press button "Validate this file"
   ==> file will be uploaded to validator
6. expected: validator will send validation result.
   actual: nothing

Comment 1

16 years ago
This works perfectly for me...
What happens when you click on "Validate this file"?
(Reporter)

Comment 2

16 years ago
Here some more information:
The complete information concerning my actual build is:
Mozilla/5.0 (Windows; U; Win98; de-AT; rv:1.3b) Gecko/20030125
(_not_ 20030126)
It might to have to to something with the size of the file.
I created a testfile with the composer - only addition to "empty page" was a
title "test".
I saved this file in the same folder, and with this one I had no problem.
Also no Problem with another little file as you find under
<http://home.t-online.de/home/Bielefeld__Buss_oHG/shop/impressum.html>
But all other bigger files cause the problem. 
The problem also happens with other "normal-sized" html-files in other folders
on ma harddisk.
I will attatch a html-file as an example.
(Reporter)

Comment 3

16 years ago
Ah, when I tried to create the attatchment with my file "shop.html" I had
another problem:
I can see that the file seems to be uploaded (I see some upload-activity on my
dsl-speedmanager), but then everythin stopps and I will not get any respons from
bugzilla that the atttchment has been received.

I will have to change to another of my mozillas to create the attatchment
(Reporter)

Comment 4

16 years ago
Created attachment 112688 [details]
testfile

I  first tried a little attatchment with Mozilla/5.0 (Windows; U; Win98; de-AT;
rv:1.3b) Gecko/20030125
(Reporter)

Comment 5

16 years ago
Created attachment 112689 [details]
Thestfile which causes Problems

With this file I had Problems 
- to validate html
- to attatch to bug with build 20030125

To create this attatchment I use 
Mozilla/5.0 (Windows; U; Win98; de-AT; rv:1.3b) Gecko/20030115
(Reporter)

Comment 6

16 years ago
to #1
as described: I se a little upload-activity, an then nothing more happens there
are no changes on the view of the site
darin, based on the timing this sounds like yours.  :(

Comment 8

16 years ago
I downloaded the second attachment and used it as the file to upload to
http://validator.w3.org/file-upload.html and it worked ok with linux trunk build
2003012522.

Is that what I should do to reproduce this bug?
(Reporter)

Comment 9

16 years ago
Bug is still actual for me with
Mozilla/5.0 (Windows; U; Win98; de-AT; rv:1.3b) Gecko/20030127(09)
(Reporter)

Comment 10

16 years ago
still actual in build 20030128

Actually I can not send bug-atts. with the actual nightlies
Severity: major → critical
duplicate of the "can't submit form with large contents" bug?

reporter, does this work in current nightlies? like, from today?
(Reporter)

Comment 12

16 years ago
Mozilla/5.0 (Windows; U; Win98; de-AT; rv:1.3b) Gecko/20030115

Christian,
I tried again with
Mozilla/5.0 (Windows; U; Win98; de-AT; rv:1.3b) Gecko/20030130
Result:
It still does not work.

Might be interesting that there are little differences in teh behavior of
non-function:
Validation ends without result and text "The W3C Markup Validation Service" in
the Tab-Register-Headline in builds
Mozilla/5.0 (Windows; U; Win98; de-AT; rv:1.3b) Gecko/20030121(08)

Validation ends without result and text "Loading...." and forever rotating
"activity-arrow" in the Tab-Register-Headline in builds
Mozilla/5.0 (Windows; U; Win98; de-AT; rv:1.3b) Gecko/20030125(08)
Mozilla/5.0 (Windows; U; Win98; de-AT; rv:1.3b) Gecko/20030130


To be shure that there is no problem with th validator, I also tested with
NN4.73 and Mozilla/5.0 (Windows; U; Win98; de-AT; rv:1.3b) Gecko/20030115
Result: Validation-Results were returned immediately. 
Mozilla/5.0 (Windows; U; Win98; de-AT; rv:1.3b) Gecko/20030115
(Reporter)

Comment 13

16 years ago
I made some additional tests.

Size of my testfile "shop.html" on harddisk: 9739 bytes.

I made some uploads with build 20030130 (no validation result)
counted uploaded bytes (traffic-counter) in 3 tests:
9408, 9446, 9362

I made some uploads with build 20030115 (_with_ validation result)
counted uploaded bytes (traffic-counter) in 3 tests:
11898, 11617, 11537

I think this test shows without doubt that the testfile is not uploaded
completely to the validator by build 20030130
(Reporter)

Comment 14

16 years ago
I also still see the problem, that I can not upload my testfile "shop.html" to
bugzilla with Mozilla/5.0 (Windows; U; Win98; de-AT; rv:1.3b) Gecko/20030130(08):
After "submit" I see "Loading..." without end.
(Reporter)

Comment 15

16 years ago
something to do with bug 191227 ?
I will test tomorrow
(Reporter)

Comment 16

16 years ago
I Think this was a dup of bug 191227
This WFM starting with
Mozilla/5.0 (Windows; U; Win98; de-AT; rv:1.3b) Gecko/20030131
So --> WRM
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.