Closed Bug 190727 Opened 17 years ago Closed 17 years ago

Text zoom also zooms pixel-defined font sizes

Categories

(Core :: Layout: Text and Fonts, defect)

defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 131236

People

(Reporter: u84638, Unassigned)

References

()

Details

User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.0) Gecko/20020530

Text zoom should be applied to text with a font size defined in points, em, 
relative sizes and so on, but not to text with a font size defined in pixels. 
This is important because a designer needs to have a choice to define a non-
zoomable text. Otherwise some kinds of layouts are not possible because they 
will be displayed corrupted.

Reproducible: Always

Steps to Reproduce:
1.Open http://www.markusernst.ch
2.Set text zoom to 200%
3.

Actual Results:  
Page layout corrupted

Expected Results:  
Display a font size defined in 12px as 12 pixels high font (or, on the other 
hand, zoom the whole page, but not only text)

In a newsgroup somebody wrote this to be a bug of Internet Explorer (which 
displays correctly). Anyway, if there is no possibility to override text zoom 
in some cases, it is not possible to make some kinds of layouts, or to combine 
text-gifs with html-text. Displaying a corrupted page layout is no help for 
disabled people, and they have other possibilities like zooming the whole 
screen or choosing a multiscan monitor with a low screen resolution anyway.
> Displaying a corrupted page layout is no help for  disabled people

You would be surprised.  In any case, that's their choice -- to not be able to
read your fonts because you made them too small or to not be able to read them
because your layout is designed in a non-scalable way.

The user's choice is more important than the designer's choice, is the
philosophy we go by.  The reason is simple -- the user is right there looking at
the page and hence can make a better decision that the designer, who has never
seen what that page looks like for that user.

*** This bug has been marked as a duplicate of 131236 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
v dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.